• poj 1562 Oil Deposits(dfs)


    Oil Deposits
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 15557   Accepted: 8431

    Description

    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

    Input

    The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

    Output

    are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

    Sample Input

    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5 
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0

    Sample Output

    0
    1
    2
    2

    Java AC 代码

    import java.util.Scanner;
    
    public class Main {
    
        static String field[][];
        
        static int rows;
        static int columns;
        
        static int pockets;
        
        static boolean marked[][];
        
        static int dx[] = {-1, 0, 1, -1, 1, -1, 0, 1};
        static int dy[] = {1, 1, 1, 0, 0, -1, -1, -1};
        
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            while((rows =sc.nextInt()) != 0 && (columns = sc.nextInt()) != 0) {
                pockets = 0;
                field = new String[rows][columns];
                marked = new boolean[rows][columns];
                for(int i = 0; i < rows; i++) {
                    String line = sc.next();
                    for(int j = 0; j < columns; j++) {
                        field[i][j] = line.substring(j, j + 1);
                    }
                }
                
                for(int i = 0; i < rows; i++)
                    for(int j = 0; j < columns; j++) {
                        if(!marked[i][j] && field[i][j].equals("@")) {
                            dfs(i, j);
                            pockets++;
                        }
                    }
                System.out.println(pockets);
            }
        }
        
        public static void dfs(int row, int col) {
            
            for(int i = 0; i < 8; i++) {
                int _row = row + dy[i];
                int _col = col + dx[i];
                if(_row < rows && _row >= 0 && _col < columns && _col >= 0 && !marked[_row][_col] && field[_row][_col].equals("@")) {
                    marked[_row][_col] = true;
                    dfs(_row, _col);
                }
            }
        }
    
    }
  • 相关阅读:
    195
    194
    193
    192
    191
    190
    Oracle 11g使用rman从单实例迁移到RAC
    RESTful API 设计指南
    Oracle GoldenGate(OGG)- 超级详细
    【转】Oracle GoldenGate OGG管理员手册
  • 原文地址:https://www.cnblogs.com/kkkkkk/p/5539909.html
Copyright © 2020-2023  润新知