• poj 1915 KnightMoves(bfs)


    Knight Moves
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 24094   Accepted: 11364

    Description

    Background 
    Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
    The Problem 
    Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
    For people not familiar with chess, the possible knight moves are shown in Figure 1. 

    Input

    The input begins with the number n of scenarios on a single line by itself. 
    Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

    Output

    For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

    Sample Input

    3
    8
    0 0
    7 0
    100
    0 0
    30 50
    10
    1 1
    1 1

    Sample Output

    5
    28
    0

    分析:简单BFS,分8个方向遍历。

    Java AC 代码

    import java.util.LinkedList;
    import java.util.Queue;
    import java.util.Scanner;
    
    public class Main {
        
        static int chessLength;
        
        static int dx[] = {-2, -2, -1, -1, 1, 1, 2, 2};
        static int dy[] = {1, -1, 2, -2, 2, -2, 1, -1};
        
        static Point original, goal;
        
        static Queue<Point> queue;
        
        static boolean marked[][];
        
        static int steps[][];
        
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int testNumber = sc.nextInt();
            
            for(int i = 1; i <= testNumber; i++) {
                chessLength = sc.nextInt();
                original = new Point(sc.nextInt(), sc.nextInt());
                goal = new Point(sc.nextInt(), sc.nextInt());
                marked = new boolean[chessLength][chessLength];
                steps = new int[chessLength][chessLength];
                queue = new LinkedList<Point> ();
                bfs();
                System.out.println(steps[goal.row][goal.col]);
            }
        }
        
        public static void bfs() {
            queue.add(original);
            marked[original.row][original.col] = true;
            steps[original.row][original.col] = 0;
            
            while(!queue.isEmpty()) {
                Point head = queue.poll();
                for(int i = 0; i < 8; i++) {
                    int _row = head.row + dy[i];
                    int _col = head.col + dx[i];
                    if(_row >= 0 && _row < chessLength && _col >= 0 && _col < chessLength && !marked[_row][_col]) {
                        queue.add(new Point(_row, _col));
                        marked[_row][_col] = true;
                        steps[_row][_col] = steps[head.row][head.col] + 1;
                    }
                }
                if(marked[goal.row][goal.col])
                    return;
            }
        }
    }
    
    class Point {
        int row;
        int col;
        public Point(int row, int col) {
            this.row = row;
            this.col = col;
        }
    }
  • 相关阅读:
    桥牌笔记:三个输墩压缩为一个
    读书笔记2013第7本:《杠杆阅读术》
    读书笔记2013第6本:《棋与人生》(一)
    《Two Dozen Short Lessons in Haskell》(二十)分数
    《Two Dozen Short Lessons in Haskell》学习(十八) 交互式键盘输入和屏幕输出
    Exercise: A Routine Day
    读书笔记2013第6本:《棋与人生》(二)
    读书笔记2013第8本:《超级快速阅读》
    TC的房子
    [转贴]Windows批处理调用程序后如何自动退出
  • 原文地址:https://www.cnblogs.com/kkkkkk/p/5539750.html
Copyright © 2020-2023  润新知