• [poj2234] Matches Game


    Description

    Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

    Input

    The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

    Output

    For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

    Sample Input

    2 45 45
    3 3 6 9
    

    Sample Output

    No
    Yes
    Solution

    Nim游戏,直接异或
    #include <stdio.h>
    int n, ans, x;
    int main()
    	{
    	while(~scanf("%d", &n))
    		{
    		ans = 0;
    		for(register int i = 0; i < n; i++) scanf("%d", &x), ans ^= x;
    		if(ans) putchar('Y'), putchar('e'), putchar('s'), putchar('
    ');
    		else putchar('N'), putchar('o'), putchar('
    ');
    		}
    	return 0;
    	}
    
  • 相关阅读:
    微信小程序设置控件权重
    从外部浏览开启app
    对rxandroid的简单理解
    react native TextInput
    使用广播来进行刷新页面
    react native中对props和state的理解
    android中四大组件之间相互通信
    android tab选项卡的使用
    android控件 ToggleButton的应用
    Listview的使用
  • 原文地址:https://www.cnblogs.com/keshuqi/p/6717840.html
Copyright © 2020-2023  润新知