• hdu 1542 & & poj 1151


    Atlantis

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 10599    Accepted Submission(s): 4524

    Problem Description
    There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
     
    Input
    The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

    The input file is terminated by a line containing a single 0. Don’t process it.
     
    Output
    For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

    Output a blank line after each test case.
     
    Sample Input
    2 10 10 20 20 15 15 25 25.5 0
     
    Sample Output
    Test case #1 Total explored area: 180.00
     
    Source

    Mid-Central European Regional Contest 2000

    题目的大意就是给定很多矩形地图,求地图能覆盖的亚特兰蒂斯的总面积。

    模仿标程写的。和之前不同,这次因为求的是笛卡尔坐标系下的长度,所以要建的是区间树,即build()修改成访问s~m和m~t,update判断标志也要改,改成l<m和m<r,我在这里卡了好久。

    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int n,len;
    double yy[250];
    struct Line{
        int f;
        double x,y1,y2;
        bool operator<(const Line h)const{
            return x<h.x;
        }
    }line[250];
    struct tree{
        int f;
        double len;
    }tr[20100];
    int bin(double x)
    {
        int l=0,r=len;
        while(l<=r){
            int mid=(l+r)>>1;
            if(yy[mid]==x)return mid;
            if(yy[mid]<x)l=mid+1;
            else r=mid-1;
        }return l;
    }
    void pushup(int s,int t,int k)
    {
        if(tr[k].f)
            tr[k].len=yy[t]-yy[s];
        else if(s+1==t)tr[k].len=0;
        else tr[k].len=tr[k<<1].len+tr[k<<1|1].len;//这里要从下向上推是因为下一次可能要用到,而要不要用考的就是f这个标记了。
    }
    void build(int s,int t,int k)
    {
        tr[k].f=tr[k].len=0;//double和int同时等于0似乎也可以,没有类型错误。
        if(s+1==t)return;//这里要注意区间树的叶节点的左右边界相差1.
        int m=(s+t)>>1;
        build(s,m,k<<1);//因为建的是区间树,所以要s~m,m~t。
        build(m,t,k<<1|1);
    }
    void update(int s,int t,int k,int l,int r,int f)
    {
        if(l<=s&&t<=r){
            tr[k].f+=f;//普通的线段树覆盖操作,这里的f不再是一般的lazy标记,而是线段使用标记。
            pushup(s,t,k);
            return;
        }int m=(s+t)>>1;
        if(l<m)update(s,m,k<<1,l,r,f);//if语句就很好地表现了其区间树与线段树的不同点。
        if(m<r)update(m,t,k<<1|1,l,r,f);
        pushup(s,t,k);
    }
    int main()
    {
        int cas=0,m;
        double x1,y1,x2,y2,ans;
        while(scanf("%d",&n)&&n){
            m=0;
            for(int i=0;i<n;i++){
                scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
                yy[m]=y1;
                line[m].f=1;
                line[m].x=x1;
                line[m].y1=y1;
                line[m++].y2=y2;
                yy[m]=y2;
                line[m].f=-1;
                line[m].x=x2;
                line[m].y1=y1;
                line[m++].y2=y2;
            }sort(yy,yy+m);
            sort(line,line+m);
            len=1;
            for(int i=1;i<m;i++)
                if(yy[i-1]!=yy[i])yy[len++]=yy[i];
            len--;
            build(0,len,1);
            ans=0;
            for(int i=0;i<m;i++){
                update(0,len,1,bin(line[i].y1),bin(line[i].y2),line[i].f);
                ans+=tr[1].len*(line[i+1].x-line[i].x);
            }printf("Test case #%d
    Total explored area: %.2f
    
    ",++cas,ans);//我看其他大牛的blog上写说.2f不会出错,但.2lf就会,不知道为什么。
        }
        return 0;
    }
    



  • 相关阅读:
    从Prism中学习设计模式之Event Aggregator 模式
    Apache的HttpClient调用Https忽略证书校验
    SaltStack安装及API开启
    Java连接WebSocket服务忽略证书校验
    SpringBoot实现WebSocket服务
    MySQL主从复制搭建
    Matlab基础知识(持续更新中)
    FIFO基础知识
    图像常识知识
    VC调试记录(持续更新中)
  • 原文地址:https://www.cnblogs.com/keshuqi/p/5957787.html
Copyright © 2020-2023  润新知