• 卡特兰数(Train Problem II )


                                                 Train Problem II

    As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.

    Input

    The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.

    Output

    For each test case, you should output how many ways that all the trains can get out of the railway.

    Sample Input

    1
    2
    3
    10

    Sample Output

    1
    2
    5
    16796
    

    它的一般项公式为:

    Hn=1n+1Cn2n=(2n)!(n+1)!n!

    递推公式为:

    Hn+1=∑i=0nHiHn−i=2(2n+1)n+2Hn(n≥0)

    
    //h( n ) = ( ( 4*n-2 )/( n+1 )*h( n-1 ) );
    
    #include<stdio.h>
    
    //*******************************
    //打表卡特兰数
    //第 n个 卡特兰数存在a[n]中,a[n][0]表示长度;
    //注意数是倒着存的,个位是 a[n][1] 输出时注意倒过来。
    //*********************************
    int a[105][100];
    void ktl()
    {
        int i,j,yu,len;
        a[2][0]=1;
        a[2][1]=2;
        a[1][0]=1;
        a[1][1]=1;
        len=1;
        for(i=3;i<101;i++)
        {
            yu=0;
            for(j=1;j<=len;j++)
            {
                int t=(a[i-1][j])*(4*i-2)+yu;
                yu=t/10;
                a[i][j]=t%10;
            }
            while(yu)
            {
                a[i][++len]=yu%10;
                yu/=10;
            }
            for(j=len;j>=1;j--)
            {
                int t=a[i][j]+yu*10;
                a[i][j]=t/(i+1);
                yu = t%(i+1);
            }
            while(!a[i][len])
            {
                len--;
            }
            a[i][0]=len;
        }
    
    }
    int main()
    {
        ktl();
        int n;
        while(scanf("%d",&n)!=EOF)
        {
            for(int i=a[n][0];i>0;i--)
            {
                printf("%d",a[n][i]);
            }
            puts("");
        }
        return 0;
    }
    
  • 相关阅读:
    跨域请求
    django数据模型中关于on_delete, db_constraint的使用
    rest-framework之分页器
    跨域请求
    相对路径与绝对路径
    html常用标签
    ES6中字符串扩展
    javascript中startswith和endsWidth 与 es6中的 startswith 和 endsWidth
    Angular6 组件树结构优化
    docker限制容器内存使用上限
  • 原文地址:https://www.cnblogs.com/jk17211764/p/9677379.html
Copyright © 2020-2023  润新知