• stack的使用Hdu 1062 Solitary


    Text Reverse

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 51495    Accepted Submission(s): 19692


    Problem Description
    Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single line with several words. There will be at most 1000 characters in a line.
     
    Output
    For each test case, you should output the text which is processed.
     
    Sample Input
    3
    olleh !dlrow
    m'I morf .udh
    I ekil .mca
     
    Sample Output
    hello world!
    I'm from hdu.
    I like acm.
     
    首先这个题就是简单的字符串反转,注意点是遇到空格怎么处理,用STL中的栈来模拟
    代码:
    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
        int n;
        char ch;
        cin>>n;
        getchar();
        while(n--){
            stack<char>s;
            while(true){
                ch = getchar();
                if(ch==' '||ch=='\n'||ch==EOF){
                    while(!s.empty()){
                        cout<<s.top();
                        s.pop();
                    } 
                    if(ch=='\n'||ch==EOF)
                        break;
                    cout<<" ";
                }
                else
                    s.push(ch);
            }
            cout<<endl;
        }
        return 0;
    }
  • 相关阅读:
    前缀和
    hdu6290奢侈的旅行
    make_pair
    New Year and Buggy Bot
    STL next_permutation 算法原理和自行实现
    前端面试题集合
    node设置cookie
    黑客与geek
    xss
    node async
  • 原文地址:https://www.cnblogs.com/jingshixin/p/12236843.html
Copyright © 2020-2023  润新知