Number Sequence
Time
Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K
(Java/Others)
Total Submission(s): 3492 Accepted Submission(s):
1581
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1
Source
Recommend
lcy
这就是个简单题,直接套模板就可以了。
#include<stdio.h>
#include<string.h>
int ch_a[1000010] , ch_b[10010];
int next[10010] , n , m , cas;
void getnext( )
{
memset(next , 0 , sizeof ( next )) ;
int i = -1 , j = 0 ;
next[0] = -1 ;
while ( j < m )
{
if ( i == -1 || ch_b[i] == ch_b[j] )
{
i ++ , j ++ ;
next[j] = i ;
}
else i = next[i] ;
}
}
int KMP ()
{
int i = 0 , j = 0 ;
while ( (i < n ) && (j < m) )
{
if ( j == -1 || ch_a[i] == ch_b[j])
{
j ++ , i ++ ;
}
else j = next[j] ;
}
if ( j == m) return i - m + 1 ;
else return -1 ;
}
int main ()
{
scanf ( "%d" , &cas ) ;
while ( cas -- )
{
memset( ch_a , 0 , sizeof ( ch_a ) ) ;
memset( ch_b , 0 , sizeof ( ch_b ) ) ;
scanf ( "%d%d%*c" , &n , &m ) ;
for ( int i = 0 ; i < n ; ++ i )
scanf ( "%d" , ch_a + i ) ;
for ( int i = 0 ; i < m ; ++ i )
scanf ( "%d" , ch_b + i ) ;
getnext () ;
printf ( "%d\n" , KMP() ) ;
}
return 0 ;
}