• 第一次写博客Poj1044


    Date bugs

    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 3005   Accepted: 889

    Description

    There are rumors that there are a lot of computers having a problem with the year 2000. As they use only two digits to represent the year, the date will suddenly turn from 1999 to 1900. In fact, there are also many other, similar problems. On some systems, a 32-bit integer is used to store the number of seconds that have elapsed since a certain fixed date. In this 
    way, when 2^32 seconds (about 136 Years) have elapsed, the date will jump back to whatever the fixed date is. 
    Now, what can you do about all that mess? Imagine you have two computers C1 and C with two different bugs: One with the ordinary Y2K-Bug (i. e. switching to a1 := 1900 instead of b1 := 2000) and one switching to a2 := 1904 instead of b2 := 2040. Imagine that the C1 displays the year y1 := 1941 and C2 the year y2 := 2005. Then you know the following (assuming that there are no other bugs): the real year can't be 1941, since, then, both computers would show the (same) right date. If the year would be 2005, y1 would be 1905, so this is impossible, too. Looking only at C1 , we know that the real year is one of the following: 1941, 2041, 2141, etc. We now can calculate what C2 would display in these years: 1941, 1905, 2005, etc. So in fact, it is possible that the actual year is 2141. 
    To calculate all this manually is a lot of work. (And you don't really want to do it each time you forgot the actual year.) So, your task is to write a program which does the calculation for you: find the first possible real year, knowing what some other computers say (yi) and knowing their bugs (switching to ai instead of bi ). Note that the year ai is definitely not after the year the computer was built. Since the actual year can't be before the year the computers were built, the year your program is looking for can't be before any ai .

    Input

    The input file contains several test cases, in which the actual year has to be calculated. The description of each case starts with a line containing an integer n (1 <= n <= 20), the number of computers. Then, there is one line containing three integers yi,ai,bi for each computer (0 <= ai <= yi < bi < 10000). yi is the year the computer displays, bi is the year in which the bug happens (i. e. the first year which can't be displayed by this computer) and ai is the year that the computer displays instead of bi . 
    The input is terminated by a test case with n = 0. It should not be processed.

    Output

    For each test case, output output the line "Case #k:", where k is the number of the situation. Then, output the line "The actual year is z.", where z is the smallest possible year (satisfying all computers and being greater or equal to u). If there is no such year less than 10000, output "Unkown bugs detected.". Output a blank line after each case.

    Sample Input

    2 
    1941 1900 2000 
    2005 1904 2040 
    2 
    1998 1900 2000 
    1999 1900 2000 
    0 

    Sample Output

    Case #1: 
    The actual year is 2141. 
    
    Case #2: 
    Unknown bugs detected. 
    

    Source

    题目大意:
    有一个日期BUG,给定日期a和b,当日期超过b时就从a开始算起。现在给定日期y a b分别代表按照错误算法的年份y,a为最小年份,b为最大年份。
    思路:
    由于第一次写博客,先挑一个水题尝试的写一下,写的不好的地方请大家见谅。本题有一个限定条件是查找的年份大于10000时,就输出"Unknown bugs detected.",这样我们直接遍历就可以了。讲讲我的代码思路吧,因为题目限制了最大的年份为10000,所以我开一个10000的数组(只要大于10000就行),将可能结果存起来,num[i]=k,其中i表示年份的可能值,k表示出现的次数。最后遍历1~10000,查出数组出现次数和给定的实例都符合则找到该正确的年份,反之亦反。最后大家直接看代码就可以,Poj上面做题主要就是注意格式和一些优化。
    import java.util.Scanner;
    public class Main{
        static int MAX = 10000;
        public static void main(String[] arg){
            Scanner scanner = new Scanner(System.in);
            int count = 1;
            while(scanner.hasNext()){
                int n = scanner.nextInt();
                int []num = new int[MAX];//可能为正确年份的数
                boolean flag = false;
                if(n==0)break;
                else{
                    for(int i=0;i<MAX;i++)num[i]=0;
                    for(int i=0;i<n;i++){//给定bug实例个数
                        int y = scanner.nextInt();
                        int a = scanner.nextInt();
                        int b = scanner.nextInt();
                        for(int j=y;j<MAX;j=j+b-a){
                            num[j]++;
                        }
                    }
                    flag = false;
                    for(int i=0;i<MAX;i++){
                        if(num[i]==n){
                            System.out.print("Case #"+count+":\n"+"The actual year is "+i+".\n\n");
                            flag = true;
                            break;
                        }
                    }
                    if(flag==false){
                        System.out.print("Case #"+count+":\n"+"Unknown bugs detected.\n\n");
                    }
                }
                count++;
            }
        }
        
        
    } 
     
     
  • 相关阅读:
    GPUImage源码解读之GPUImageFramebuffer
    CSS之定位
    CSS之浮动
    CSS之盒子模型
    CSS之元素
    CSS之选择器
    iOS图片瘦身总结
    iOS动画——CoreAnimation
    iOS动画——DynamicAnimate
    iOS动画——UIKit动画
  • 原文地址:https://www.cnblogs.com/jave1ove/p/5456124.html
Copyright © 2020-2023  润新知