• 省赛热身赛之——Yet Another Story of Rockpaperscissors


    原题:

    Description

    Akihisa and Hideyoshi were lovers. They were sentenced to death by the FFF Inquisition. Ryou, the leader of the FFF Inquisition, promised that the winner of Rock-paper-scissors would be immune from the punishment. Being lovers, Akihisa and Hideyoshi decided to die together with their fists clenched, which indicated rocks in the game. However, at the last moment, Akihisa chose paper and Hideyoshi chose scissors. As a result, Akihisa was punished by the FFF Inquisition and Hideyoshi survived alone.

    When a boy named b and a girl named g are being punished by the FFF Inquisition, they will play Rock-paper-scissors and the winner will survive. If there is a tie, then neither of they will survive. At first, they promise to choose the same gesture x. But actually, the boy wants to win and the girl wants to lose. Of course, neither of them knows that the other one may change his/her gesture. At last, who will survive?

    Input

    There are multiple test cases. The first line of input is an integer T ≈ 1000 indicating the number of test cases.

    Each test case contains three strings -- b g x. All strings consist of letters and their lengths never exceed 20. The gesture x is always one of "rock", "paper" and "scissors".

    Output

    If there is a tie, output "Nobody will survive". Otherwise, output "y will survive" where y is the name of the winner.

    Sample Input

    1
    Akihisa Hideyoshi rock
    

    Sample Output

    Hideyoshi will survive

    分析:

    以前看过这样的故事——

    说的是同样的情况,男孩不想让女孩死,先是两人都出了石头,结果最后男孩出了剪刀,女孩出了布。。。。。。。。。。这篇文章反了吧??????????

     

     

    枚举,发现都是女孩胜利。

    源码:

    #include<stdio.h>
    int main()
    {
        char a[300],b[300],c[200];
        int n;
        scanf("%d",&n);
        while(n--)
        {
            scanf("%s%s%s",a,b,c);
            printf("%s will survive\n",b);
        }
        return 0;
    }
    


     

  • 相关阅读:
    4412--PWM驱动部分
    Linux中进程与线程
    Linux 进程间通信 --信号量
    Linux 进程间通信 --消息队列
    Linux 进程间通信 --共享内存
    QByteArray转成十六进制的QString
    网易C++设计模式笔记(二)面向设计对象的原则
    网易C++设计模式笔记(一)
    windows安装系统记录
    设计模式解析第二版 课后习题自我解答
  • 原文地址:https://www.cnblogs.com/javawebsoa/p/3043265.html
Copyright © 2020-2023  润新知