• HDU 3074 Multiply game (线段树)


    Multiply game

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1055    Accepted Submission(s): 343


    Problem Description
    Tired of playing computer games, alpc23 is planning to play a game on numbers. Because plus and subtraction is too easy for this gay, he wants to do some multiplication in a number sequence. After playing it a few times, he has found it is also too boring. So he plan to do a more challenge job: he wants to change several numbers in this sequence and also work out the multiplication of all the number in a subsequence of the whole sequence.
      To be a friend of this gay, you have been invented by him to play this interesting game with him. Of course, you need to work out the answers faster than him to get a free lunch, He he…

     
    Input
    The first line is the number of case T (T<=10).
      For each test case, the first line is the length of sequence n (n<=50000), the second line has n numbers, they are the initial n numbers of the sequence a1,a2, …,an, 
    Then the third line is the number of operation q (q<=50000), from the fourth line to the q+3 line are the description of the q operations. They are the one of the two forms:
    0 k1 k2; you need to work out the multiplication of the subsequence from k1 to k2, inclusive. (1<=k1<=k2<=n) 
    1 k p; the kth number of the sequence has been change to p. (1<=k<=n)
    You can assume that all the numbers before and after the replacement are no larger than 1 million.
     
    Output
    For each of the first operation, you need to output the answer of multiplication in each line, because the answer can be very large, so can only output the answer after mod 1000000007.
     
    Sample Input
    1 6 1 2 4 5 6 3 3 0 2 5 1 3 7 0 2 5
     
    Sample Output
    240 420
     
    Source
     
    Recommend
    lcy
     

    题意:两种操作
    0 k1 k2; you need to work out the multiplication of the subsequence from k1 to k2, inclusive.
    1 k p; the kth number of the sequence has been change to p. (1<=k<=n)

    思路:线段树 跟前面做的几道对比 有点简单了 但要注意要用__int64 而且每乘完后都要取模

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    #define L(rt) (rt<<1)
    #define R(rt) (rt<<1|1)
    
    const int mod=1000000007;
    const int N=50010;
    
    int num[N];
    
    struct node{
        int l,r;
        long long ans;
    }tree[N*3];
    
    void build(int l,int r,int rt){
        tree[rt].l=l;
        tree[rt].r=r;
        if(l==r){
            tree[rt].ans=num[l];
            return ;
        }
        int mid=(l+r)>>1;
        build(l,mid,L(rt));
        build(mid+1,r,R(rt));
        tree[rt].ans=(tree[L(rt)].ans*tree[R(rt)].ans)%mod;
    }
    
    long long query(int l,int r,int rt){
        if(tree[rt].l==l && tree[rt].r==r)
            return tree[rt].ans;
        int mid=(tree[rt].l+tree[rt].r)>>1;
        if(r<=mid)
            return query(l,r,L(rt));
        else if(l>=mid+1)
            return query(l,r,R(rt));
        else{
            long long a=query(l,mid,L(rt));
            long long b=query(mid+1,r,R(rt));
            return (a*b)%mod;
        }
    }
    
    void update(int val,int loc,int rt){
        if(tree[rt].l==loc && tree[rt].r==loc){
            tree[rt].ans=val;
            return ;
        }
        if(loc<=tree[L(rt)].r)
            update(val,loc,L(rt));
        if(loc>=tree[R(rt)].l)
            update(val,loc,R(rt));
        tree[rt].ans=(tree[L(rt)].ans*tree[R(rt)].ans)%mod;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t,n,m;
        scanf("%d",&t);
        while(t--){
            scanf("%d",&n);
            for(int i=1;i<=n;i++)
                scanf("%d",&num[i]);
            build(1,n,1);
            scanf("%d",&m);
            int op,x,y;
            while(m--){
                scanf("%d%d%d",&op,&x,&y);
                if(op==0){
                    long long ans=query(x,y,1);
                    printf("%I64d\n",ans%mod);
                }else
                    update(y,x,1);
            }
        }
        return 0;
    }
  • 相关阅读:
    洛谷P1328 生活大爆炸版石头剪刀布
    洛谷P1131 [ZJOI2007]时态同步
    洛谷P2585 [ZJOI2006]三色二叉树
    机器学习实战四(Logistic Regression)
    机器学习实战三(Naive Bayes)
    机器学习实战二 (Decision Tree)
    机器学习实战一(kNN)
    chapter9 拖放
    Stanford Algorithms(一): 大数相乘(c++版)
    读: 程序员之禅
  • 原文地址:https://www.cnblogs.com/jackge/p/3040104.html
Copyright © 2020-2023  润新知