• HDU 2289 Cup (二分)


    Cup

    Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 2356    Accepted Submission(s): 741


    Problem Description
    The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height? 

    The radius of the cup's top and bottom circle is known, the cup's height is also known.
     
    Input
    The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
    Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.

    Technical Specification

    1. T ≤ 20.
    2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
    3. r ≤ R.
    4. r, R, H, V are separated by ONE whitespace.
    5. There is NO empty line between two neighboring cases.

     
    Output
    For each test case, output the height of hot water on a single line. Please round it to six fractional digits.
     
    Sample Input
    1
    100 100 100 3141562
     
    Sample Output
    99.999024
     
    Source
     
    Recommend
    lcy
     

    二分
    题目大意:一个圆台型的杯子,告诉杯子的上底和下底的半径、杯子的高度,以及水的体积,要求水的高度。
    算法分析:

    /*
    水平面的半径u可以根据直角梯形的面积求出:
    (r+u)*h + (u+R)*(H-h) = (r+R)*H
    得出(R-r)*h = (u-r)*H
    得 u = r + (R-r)*h/H
    圆台体积计算公式:V= π*h*( R^2 + R*u + u^2 ) / 3
    */

     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    
    using namespace std;
    
    #define eps 1e-8
    
    double PI=acos(-1);
    double r,R,H,V;
    
    double cal(double x){
        double u=(R-r)*x/H+r;
        return PI*x*(pow(r,2)+pow(u,2)+r*u)/3;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t;
        scanf("%d",&t);
        while(t--){
            scanf("%lf%lf%lf%lf",&r,&R,&H,&V);
            double left=0,right=H;
            double mid;
            while(right-left>eps){
                mid=(right+left)/2;
                if(cal(mid)-V>eps)
                    right=mid;
                else
                    left=mid;
            }
            printf("%.6lf\n",mid);
        }
        return 0;
    }
  • 相关阅读:
    如何判断某个设备文件是否存在
    shell中export理解误区
    linux命令之tail
    国内较快的gnu镜像:北京交通大学镜像
    Cmake的交叉编译
    linux 命令之grep
    makefile之变量赋值
    makefile之VPATH和vpath的使用
    arm汇编进入C函数分析,C函数压栈,出栈,传参,返回值
    Jlink 软件断点和硬件断点
  • 原文地址:https://www.cnblogs.com/jackge/p/3029750.html
Copyright © 2020-2023  润新知