• HDU 2069 Coin Change (母函数 | 背包 )


    Coin Change

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 9842    Accepted Submission(s): 3300

    Problem Description
    Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.
    For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.
    Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
     
    Input
    The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
     
    Output
    For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
     
    Sample Input
    11
    26
     
    Sample Output
    4
    13
     
    Author
    Lily
     
    Source
     
    Recommend
    linle
     
     
    1,母函数:
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int N=300;
    
    int c1[N][110],c2[N][110];
    int res[N],money[6]={0,1,5,10,25,50};
    
    void Init(){
        memset(c1,0,sizeof(c1));
        memset(c2,0,sizeof(c2));
        c1[0][0]=1;
        for(int i=1;i<=5;i++){
            for(int j=0;j<=250;j++)
                for(int k=0;j+k*money[i]<=250;k++)
                    for(int p=0;k+p<=100;p++)       //限制硬币总数不超过100
                        c2[j+k*money[i]][p+k]+=c1[j][p];
            for(int j=0;j<=250;j++)
                for(int p=0;p<=100;p++){    //限制硬币总数不超过100
                    c1[j][p]=c2[j][p];
                    c2[j][p]=0;
                }
        }
        for(int i=1;i<=250;i++)
            for(int j=0;j<=100;j++)
                res[i]+=c1[i][j];
        res[0]=1;       //别忘了这个
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int n;
        Init();
        while(~scanf("%d",&n)){
            printf("%d\n",res[n]);
        }
        return 0;
    }
     

    2,背包:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    int n,dp[110][300];     // dp[j][k] 统计到第i个coins k钱 dived to j 部分 的分法数
    int money[5]={1,5,10,25,50};
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d",&n)){
            memset(dp,0,sizeof(dp));
            dp[0][0]=1;
            for(int i=0;i<5;i++)
                for(int j=1;j<=100;j++)
                    for(int k=n;k>=money[i];k--)    //这样写应该使对的,可写成这样for(int k=money[i];k<=n;k++) 也没WA,估计数据弱了
                        dp[j][k]+=dp[j-1][k-money[i]];
            int ans=0;
            for(int i=0;i<=100;i++) //从0开始,注意 dp[0][0]
                ans+=dp[i][n];
            printf("%d\n",ans);
        }
        return 0;
    }
  • 相关阅读:
    [转]GPS原始数据说明
    [转]标准USB,MiniUSB接口定义
    warning C4819: 该文件包含不能在当前代码页(936)中表示的字符
    with用法
    turn out用法
    keep用法
    Stop doing和Stop to do和Stop...from doing有什么不同
    figure用法
    wanna用法
    seem用法
  • 原文地址:https://www.cnblogs.com/jackge/p/3028319.html
Copyright © 2020-2023  润新知