• HDU 4432 Sum of divisors


    Sum of divisors

    http://acm.hdu.edu.cn/showproblem.php?pid=4432

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 875    Accepted Submission(s): 342

    Problem Description
    mmm is learning division, she's so proud of herself that she can figure out the sum of all the divisors of numbers no larger than 100 within one day! But her teacher said "What if I ask you to give not only the sum but the square-sums of all the divisors of numbers within hexadecimal number 100?" mmm get stuck and she's asking for your help. Attention, because mmm has misunderstood teacher's words, you have to solve a problem that is a little bit different. Here's the problem, given n, you are to calculate the square sums of the digits of all the divisors of n, under the base m.
     
    Input
    Multiple test cases, each test cases is one line with two integers. n and m.(n, m would be given in 10-based) 1≤n≤109 2≤m≤16 There are less then 10 test cases.
     
    Output
    Output the answer base m.
     
    Sample Input
     
    10 2
    30 5
     
    Sample Output
     
    110
    112
    Hint
    Use A, B, C...... for 10, 11, 12...... Test case 1: divisors are 1, 2, 5, 10 which means 1, 10, 101, 1010 under base 2, the square sum of digits is 1^2+ (1^2 + 0^2) + (1^2 + 0^2 + 1^2) + .... = 6 = 110 under base 2.
     
    Source
     
     
     
    #include<stdio.h>
    #include<math.h>
    
    int n,m;
    int bit[10000],cnt;
    
    void change(int n,int base){
        cnt=0;
        while(n){
            bit[cnt++]=n%base;
            n/=base;
        }
    }
    
    int main(){
        while(scanf("%d%d",&n,&m)!=EOF){
            int sum=0,i;
            int t=(int)sqrt(n*1.0);
            for(i=1;i<=t;i++)
                if(n%i==0){
                    int tmp=i;
                    while(tmp){
                        sum+=(tmp%m)*(tmp%m);
                        tmp/=m;
                    }
                    tmp=n/i;
                    if(tmp==i)
                        continue;
                    while(tmp){
                        sum+=(tmp%m)*(tmp%m);
                        tmp/=m;
                    }
                }
            change(sum,m);
            for(i=cnt-1;i>=0;i--)
                if(bit[i]>=10)
                    printf("%c",bit[i]-10+'A');
                else
                    printf("%d",bit[i]);
            printf("\n");
        }
        return 0;
    }
  • 相关阅读:
    HDU 1081 To The Max (DP) 扩展最大子列和,求最大子矩阵和
    How to Log SOAP Message Content in Metro?(官方解答)
    纪晓岚与和珅对调后的工作困难
    蒙版
    2011年选拔赛C本科
    网络常用语
    linux怎么用一个命令行统计出给定目录中有多少个子目录
    REGSVR32
    香水
    判断一个数是否是2的平方
  • 原文地址:https://www.cnblogs.com/jackge/p/2835344.html
Copyright © 2020-2023  润新知