• PKU 1011 Sticks


    Sticks

    http://poj.org/problem?id=1011

    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 103691   Accepted: 23627

    Description

    George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

    Input

    The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

    Output

    The output should contains the smallest possible length of original sticks, one per line.

    Sample Input

    9
    5 2 1 5 2 1 5 2 1
    4
    1 2 3 4
    0
    

    Sample Output

    6
    5

    Source

     
    DFS练习:
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    
    using namespace std;
    
    const int N=70;
    
    int n,len,num;
    int sticks[N],vis[N];
    int flag;
    
    int cmp(int a,int b){
        return a>b;
    }
    
    void DFS(int k,int cur,int cnt){
        if(flag)
            return;
        if(cnt==num){
            flag=1;
            return ;
        }
        if(cur==len)
            DFS(0,0,cnt+1);
        else{
            int pre=-1;
            for(int i=k;i<n;i++)
                if(!vis[i] && sticks[i]+cur<=len && sticks[i]!=pre){
                    pre=sticks[i];
                    vis[i]=1;
                    DFS(i+1,sticks[i]+cur,cnt);
                    vis[i]=0;
                    if(k==0 || flag)
                        return ;
                }
        }
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d",&n) && n){
            int sum=0;
            flag=0;
            for(int i=0;i<n;i++){
                scanf("%d",&sticks[i]);
                sum+=sticks[i];
            }
            sort(sticks,sticks+n,cmp);
            for(len=sticks[0];len<=sum;len++)
                if(sum%len==0){
                    num=sum/len;
                    memset(vis,0,sizeof(vis));
                    DFS(0,0,0);
                    if(flag)
                        break;
                }
            printf("%d\n",flag?len:sum);
        }
        return 0;
    }
  • 相关阅读:
    软件项目成员的业绩考核
    COM, COM+ and .NET 程序集的区别
    .Net 应用框架设计系列(二)
    怎样在Web开发中完美控制IE标题栏
    影楼系统
    PHP读取ACCESS数据到MYSQL
    简单分享apache 封 IP 的方法
    详解Apache下.htaccess文件常用配置
    fleaphp常用方法分页之Pager
    php遍历文件夹读取文件夹中图片并分页显示图片
  • 原文地址:https://www.cnblogs.com/jackge/p/2832793.html
Copyright © 2020-2023  润新知