• POJ 3468 A Simple Problem with Integers (成端更新)


    A Simple Problem with Integers
    Time Limit: 5000MS   Memory Limit: 131072K
    Total Submissions: 41842   Accepted: 12156
    Case Time Limit: 2000MS

    Description

    You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

    Input

    The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
    The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
    Each of the next Q lines represents an operation.
    "C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
    "Q a b" means querying the sum of AaAa+1, ... , Ab.

    Output

    You need to answer all Q commands in order. One answer in a line.

    Sample Input

    10 5
    1 2 3 4 5 6 7 8 9 10
    Q 4 4
    Q 1 10
    Q 2 4
    C 3 6 3
    Q 2 4
    

    Sample Output

    4
    55
    9
    15

    Hint

    The sums may exceed the range of 32-bit integers.

    Source

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int maxn=100010;
    
    #define lson l,mid,rt<<1
    #define rson mid+1,r,rt<<1|1
    
    int n,q;
    long long sum[maxn<<2];
    long long add[maxn<<2];
    
    void Push_Up(int rt) {
        sum[rt] = sum[rt<<1] + sum[rt<<1|1];
    }
    
    void Push_Down(int rt,int m) {
        if (add[rt]) {
            add[rt<<1] += add[rt];
            add[rt<<1|1] += add[rt];
            sum[rt<<1] += add[rt] * (m - (m >> 1));
            sum[rt<<1|1] += add[rt] * (m >> 1);
            add[rt] = 0;
        }
    }
    
    void build(int l,int r,int rt) {
        add[rt] = 0;
        if (l == r) {
            scanf("%I64d",&sum[rt]);
            return ;
        }
        int mid = (l + r) >> 1;
        build(lson);
        build(rson);
        Push_Up(rt);
    }
    
    void update(int L,int R,int c,int l,int r,int rt) {
        if (L <= l && r <= R) {
            add[rt] += c;
            sum[rt] += (long long)c * (r - l + 1);
            return ;
        }
        Push_Down(rt , r - l + 1);
        int mid = (l + r) >> 1;
        if (L <= mid) update(L , R , c , lson);
        if (mid < R) update(L , R , c , rson);
        Push_Up(rt);
    }
    
    long long query(int L,int R,int l,int r,int rt) {
        if (L <= l && r <= R) {
            return sum[rt];
        }
        Push_Down(rt , r - l + 1);
        int mid = (l + r) >> 1;
        long long ret = 0;
        if (L <= mid) ret += query(L , R , lson);
        if (mid < R) ret += query(L , R , rson);
        return ret;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d%d",&n,&q)){
            build(1,n,1);
            char op[3];
            int a,b,c;
            while(q--){
                scanf("%s",op);
                if (op[0] == 'Q') {
                    scanf("%d%d",&a,&b);
                    printf("%I64d\n",query(a , b , 1 , n , 1));
                } else {
                    scanf("%d%d%d",&a,&b,&c);
                    update(a , b , c , 1 , n , 1);
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    Class.getSimpleName()的作用
    win7下制作ubuntu系统安装启动盘和U盘安装ubuntu全过程
    奈奎斯特三大准则
    [转]OFDM中保护间隔和循环前缀抵抗ISI和ICI
    频偏
    移动通信里面,OFDM技术所说的“载波相互正交”是什么意思?
    虚拟盘符映射
    npm 安装与常用命令
    ASP.NET WebAPI HTTPS
    记录下自己写的gulp打包脚本
  • 原文地址:https://www.cnblogs.com/jackge/p/3026750.html
Copyright © 2020-2023  润新知