• HDU-1003 Max Sum


    Problem Description
    Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
     
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
     
    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
     
    Sample Input
    2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
     
    Sample Output
    Case 1: 14 1 4
     
     
    Case 2: 7 1 6

    思路:
    最近开始复习下DP,这是最经典的最大子段和问题了,具体的方法没什么好赘述的,有两点要注意下:
    (1)所有数都是负数这种情况应该单独拿出来处理一下,除此之外只要有一个非负数都可以当做正常的情况来处理
    (2)记录开始和结束位置的问题,首先考虑的是问题是什么时候去更新b和e,通过观察发现是在每次ans被更新的时候和每次tm清零的时候;其次要考虑的是更新的正确性,一开始我只是在ans更新的时候设置了一个e = i;然后在tm<0的时候设置了一个 b = e = i+1;而这就会出现错误的情况:当已经确定了某个连续子段的最大值时,如果tm的值<0了,那之前的位置记录就消失了。对于这个问题我突然想到了一种方法,就是建立一种概念————当前最大值的开始结束位置和历史最大值的开始结束位置,然后再在适时的地方做好b和e的更新工作,这样就能顺利的AC。通过这点我发现一个程序终究是解决问题的工具,只要概念上的东西是正确的,然后程序对思想的表达没有偏差,那么问题就能够得到解决。这是一个进步的过程,我之所以这样想,是因为我终于意识到成功的程序是人操控程序,而非程序来限制人的思维

    #include <iostream>
    #include <cstring>
    using namespace std;
    
    int main()
    {
        int n;
        int c = 0;
        int T;
        cin>>T;
        while(T--)
        {
            c++;
            int ans = 0;
            int tm = 0;
            int b,e,b_m,e_m;
            int b_n,e_n;
            b = e = 1;
            b_n = e_n = 1;
            cin>>n;
            int cnt = 0;
            int m = -1008;
            for(int i = 1;i <= n;i++)
            {
                int t;
                cin>>t;
                if(t < 0) {
                    cnt++;
                    if(t > m) { //求绝对值最小的负数的位置
                        m = t;
                        b_m = e_m = i;
                    }
                }
                tm += t;
                if(tm < 0) {
                    tm = 0;
                    b_n = e_n = i+1;
                    continue;
                }
                if(tm >= ans) {
                    ans = tm;
                    //问题只剩下该如何处置b和e
                    e = i; 
                    e_n = i;
                    b = b_n;
                }
            }
            //判断负数的个数
            if(cnt == n) {
                b = b_m;
                e = e_m;
                ans = m;
            }
            //输出最后的结果 
            if(T == 0) {
                cout<<"Case "<<c<<':'<<endl;
                cout<<ans<<' '<<b<<' '<<e<<endl;
            }
            else {
                cout<<"Case "<<c<<':'<<endl;
                cout<<ans<<' '<<b<<' '<<e<<endl<<endl;
            }
        }
        return 0;
    }
  • 相关阅读:
    Git安装及配置-拉取远程仓库代码
    Leangoo领歌敏捷项目管理工具新增测试管理功能
    Xcode中的Vim--XVim
    npm安装报错:源文本中存在无法识别的标记
    给找不到类型文件的依赖增加TypeScript类型声明
    输入框为空时,按钮灰色不可点
    Django settings.py设置 DEBUG=False后静态文件无法加载解决
    mongodb系列~开发规范
    mongodb系列~升级版本
    CIM基础平台性能指标
  • 原文地址:https://www.cnblogs.com/immortal-worm/p/5149298.html
Copyright © 2020-2023  润新知