• NYOJ 题目94 cigarettes


    题目描述:

    Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them

    one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette. 
    Now,do you know how many cigarettes can Tom has?

    输入
    First input is a single line,it's n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.
    输出
    For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
    样例输入
    3
    4 3
    10 3
    100 5
    样例输出
    5
    14
    124
    大致意思是假设汤姆有n支香烟,每吸k支香烟就会得到一支新的香烟,求汤姆最多能吸多少支香烟?

    #include<stdio.h>
    int main()
    {
    int N;
    scanf("%d",&N);
    while(N--)
    {
    int n,k,i;
    int sum=0;
    scanf("%d %d",&n,&k);
    for(i=1;i<=n;i++)
    {
    sum=sum+1;
    if(sum%k==0)
    n=n+1;
    }
    printf("%d",sum);
    printf(" ");
    }
    }

    //AC

    欢迎各路大神评论!

     
    
    
  • 相关阅读:
    04: Dom
    03: JavaScript基础
    02: css常用属性
    01: html常用标签
    03: Memcached
    01: Redis缓存系统
    01: RabbitMQ
    04: 事件驱动、五种I/O操作、I/O多路复用select和epoll
    03: 进程、线程、协程
    [Android] 任意时刻从子线程切换到主线程的实现
  • 原文地址:https://www.cnblogs.com/hys1258414454/p/7225227.html
Copyright © 2020-2023  润新知