• POJ 2528 QAQ段树+分离


    Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

    Description

    The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
    • Every candidate can place exactly one poster on the wall.
    • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
    • The wall is divided into segments and the width of each segment is one byte.
    • Each poster must completely cover a contiguous number of wall segments.

    They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
    Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.

    Input

    The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

    Output

    For each input data set print the number of visible posters after all the posters are placed.

    The picture below illustrates the case of the sample input.

    Sample Input

    1
    5
    1 4
    2 6
    8 10
    3 4
    7 10
    

    Sample Output

    4
    




    開始没有离散化处理导致内存超了,离散化就过了。。。。

    /*************************************************************************
        > File Name: B.cpp
        > Author: acvcla
        > QQ: 1319132622
        > Mail: acvcla@gmail.com
        > Created Time: 2014年10月04日 星期六 16时24分37秒
     ************************************************************************/
    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    #include<vector>
    #include<cstring>
    #include<map>
    #include<queue>
    #include<stack>
    #include<string>
    #include<cstdlib>
    #include<ctime>
    #include<set>
    #include<math.h>
    using namespace std;
    typedef long long LL;
    const int maxn = 1e5 + 10;
    #define rep(i,a,b) for(int i=(a);i<(b);i++)
    #define pb push_back
    short int col[maxn<<3];
    bool v[maxn<<2];
    int ll[maxn],rr[maxn],ttp[maxn<<3];
    void push_down(int o){
    	if(col[o]!=-1){
    		col[o<<1]=col[o<<1|1]=col[o];
    		col[o]=-1;
    	}
    }
    void push_up(int o){
    	if(col[o<<1]==col[o<<1|1])col[o]=col[o<<1];
    	else col[o]=-1;
    }
    int ql,qr,x;
    void built(int o,int l,int r)
    {
    	col[o]=0;
    	if(l==r)return;
    	int M=(l+r)>>1;
    	built(o<<1,l,M);
    	built(o<<1|1,M+1,r);
    }
    void Modify(int o,int l,int r){
    	if(ql<=l&&qr>=r){
    		col[o]=x;
    		return;
    	}
    	int M=(l+r)>>1;
    	push_down(o);
    	if(ql<=M)Modify(o<<1,l,M);
    	if(qr>M)Modify(o<<1|1,M+1,r);
    	push_up(o);
    }
    int query(int o,int l,int r){
    	if(col[o]!=-1){
    		if(!col[o]||v[col[o]])return 0;
    		else{
    			v[col[o]]=true;
    			return 1;
    		}
    	}
    	if(l==r)return 0;
    	int M=(l+r)>>1;
    	push_down(o);
    	return query(o<<1,l,M)+query(o<<1|1,M+1,r);
    }
    int main(){
    		ios_base::sync_with_stdio(false);
    		cin.tie(0);
    		int n,T;cin>>T;
    		while(T--){
    			x=0;
    			cin>>n;
    			memset(v,0,sizeof v);
    			int cnt=0;
    			for(int i=1;i<=n;i++){
    				cin>>ll[i]>>rr[i];
    				ttp[++cnt]=ll[i];
    				ttp[++cnt]=rr[i];
    			}
    			sort(ttp+1,ttp+1+cnt);
    			cnt=unique(ttp+1,ttp+1+cnt)-ttp;
    			int t=cnt;
    			for(int i=1;i<t;i++)
    			{
    				if(ttp[i]+1!=ttp[i+1])ttp[++cnt]=ttp[i]+1;
    			}
    			sort(ttp+1,ttp+1+cnt);
    			built(1,1,cnt);
    			for(int i=1;i<=n;i++){
    				x=i;
    				ql=lower_bound(ttp+1,ttp+1+cnt,ll[i])-ttp;
    				qr=lower_bound(ttp+1,ttp+1+cnt,rr[i])-ttp;
    				Modify(1,1,cnt);
    			}
    			cout<<query(1,1,cnt)<<endl;
    		}
    		return 0;
    }
    


    版权声明:本文博客原创文章。博客,未经同意,不得转载。

  • 相关阅读:
    Bootstrap3 formテキストフィールド横幅の指定の仕方
    HTML豆ちしき
    iMac Termanel命令まとめ
    ちょっとした難しい言葉まとめ①
    即使痛苦,绝不止步
    Bower —— 一个Web的包管理工具
    词汇
    8.3.2018 1 Quick and dirty 快而脏的快餐
    7.26 5 优化浪漫 恋爱中的经济学
    7.26 4 印度旅馆阿鲁沙之家
  • 原文地址:https://www.cnblogs.com/hrhguanli/p/4750863.html
Copyright © 2020-2023  润新知