• 杭电 2602 Bone Collector


    Bone Collector

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 27413    Accepted Submission(s): 11154


    Problem Description
    Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
    The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

     

    Input
    The first line contain a integer T , the number of cases.
    Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
     

    Output
    One integer per line representing the maximum of the total value (this number will be less than 231).
     

    Sample Input
    1 5 10 1 2 3 4 5 5 4 3 2 1
     

    Sample Output
    14

    01背包。


    AC代码例如以下:


    #include<iostream>
    #include<cstring>
    using namespace std;
    int main()
    {
        int t,n,v;
        int i,j;
        int a[1005],b[1005],dp[1005];
        cin>>t;
        while(t--)
        {
            cin>>n>>v;
            for(i=1;i<=n;i++)
                cin>>a[i];
            for(i=1;i<=n;i++)
                cin>>b[i];
            memset(dp,0,sizeof dp);
            for(i=1;i<=n;i++)
                for(j=v;j>=b[i];j--)
                dp[j]=max(dp[j-b[i]]+a[i],dp[j]);
                cout<<dp[v]<<endl;
        }
    
        return 0;
    }


  • 相关阅读:
    JDK安装,环境配置
    XSS攻击测试代码
    css3 input边框蓝光特效
    PDFobject插件使用,PDF在线查看插件
    网页中嵌入可以点击“运行代码”执行html/css/js代码
    SmohanTimeLine.js 酷炫的时间轴效果
    java进行文件上传,带进度条
    javascript读取xml文件
    C# 动态类型与动态编译简介
    Mac 命令行美化
  • 原文地址:https://www.cnblogs.com/hrhguanli/p/3809349.html
Copyright © 2020-2023  润新知