• Digital Roots


    Digital Roots

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 65092    Accepted Submission(s): 20292

    Problem Description
    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
     
    Input
    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
     
    Output
    For each integer in the input, output its digital root on a separate line of the output.
     
    Sample Input
    24 39 0
     
    Sample Output
    6 3

    本题我刚开始没有考虑输入的整数无穷大情况,就固定了输入数据类型,后来改为string,但是求得和还是可能无穷大,这一点没考虑但是程序居然通过了,汗

    #include<iostream>
    #include<string>


    using namespace std;

    int getRootInt(int value)
    {
    int sum=0;
    int tempValue=value;
    while(tempValue!=0)
    {
    sum+=tempValue%10;
    tempValue=tempValue/10;
    }
    if(sum>9)
    {
    sum=getRootInt(sum);
    }
    return sum;
    }


    int getRoot(string value)
    {
    int sum=0;
    for(int i=0;i<value.length();i++)
    {
    sum+=value[i]-'0';
    }
    return getRootInt(sum);
    }


    int main()
    {
    string value="";//不能定义固定类型可能无穷大
    while(cin>>value)
    {
    if(value=="0")break;
    int sum=0;
    sum=getRoot(value);
    cout<<sum<<endl;
    }
    return 0;
    }

  • 相关阅读:
    (一)研究方法入门
    机器学习入门之认知
    夯实Java:从面向对象说起
    不同子系统采用不同MySQL编码LATIN1和UTF8的兼容
    性能优化 java 24 次阅读 · 读完需要 15 分钟 0
    如何用纯 CSS 创作一个充电 loader 特效
    如何用纯 CSS 创作一个 3D 文字跑马灯特效
    如何用纯 CSS 绘制一颗闪闪发光的璀璨钻石
    如何用 CSS 创作一个立体滑动 toggle 交互控件
    如何用纯 CSS 创作一个金属光泽 3D 按钮特效
  • 原文地址:https://www.cnblogs.com/honeybusybee/p/5223551.html
Copyright © 2020-2023  润新知