• HDU 1398 Square Coins(DP)


    Square Coins

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 8800    Accepted Submission(s): 5991


    Problem Description
    People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
    There are four combinations of coins to pay ten credits: 

    ten 1-credit coins,
    one 4-credit coin and six 1-credit coins,
    two 4-credit coins and two 1-credit coins, and
    one 9-credit coin and one 1-credit coin. 

    Your mission is to count the number of ways to pay a given amount using coins of Silverland.
     
    Input
    The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
     
    Output
    For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 
     
    Sample Input
    2
    10
    30
    0
     
    Sample Output
    1
    4
    27
     
     
    题意是用平方数来构成一个数字,有多少种不同的组成方案 。
    一开始想用以为,发现是有很多重复情况的。比如说10 = 1 + 9 = 9 + 1 是不太好维护的
     
    二维的做法就是用dp[i][j] ..表示用前i个平方数(0<i<=17)组成数字j的方案数。
    这样就保证了不重复计算了 。
     
     
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <string>
    #include <cmath>
    #include <vector>
    #include <queue>
    #include <map>
    #include <set>
    #include <stack>
    #include <algorithm>
    using namespace std;
    #define root 1,n,1
    #define lson l,mid,rt<<1
    #define rson mid+1,r,rt<<1|1
    #define lr rt<<1
    #define rr rt<<1|1
    typedef long long LL;
    typedef pair<int,int>pii;
    #define X first
    #define Y second
    const int oo = 1e9+7;
    const double PI = acos(-1.0);
    const double eps = 1e-6 ;
    const int N = 305 ;
    const int mod = 1e9+7;
    LL dp[N][N];
    int n ;
    void init() {
        dp[0][0] = 1 ;
        for( int i = 1 ; i <= 17 ; ++i ){
            for( int j = 0 ; j < N ; ++j ){
                for( int k = 0 ; k <= j ; k += i * i ){
                    dp[i][j] += dp[i-1][j-k];
                }
            }
        }
    }
    void Run() {
        if( !n ) return ;
        cout << dp[17][n] << endl;
    }
    int main()
    {
        #ifdef LOCAL
            freopen("in.txt","r",stdin);
        #endif // LOCAL
        ios::sync_with_stdio(false);
        init(); while( cin >> n ) Run();
    }
    View Code
    only strive for your goal , can you make your dream come true ?
  • 相关阅读:
    接口和抽象类的区别
    MFC之ListCtrl动态添加按钮
    C++类间转换之dynamic_cast
    字符串提取
    C++实现快速排序
    MFC中CListCtrl类依靠CImageList贴图并显示不同图像
    北工大耿丹学院16级计科院3班C语言课程助教学期总结
    C语言课程2——我们交流的工具:Coding.net
    salt-minion安装脚本
    zabbix邮件报警脚本
  • 原文地址:https://www.cnblogs.com/hlmark/p/4202783.html
Copyright © 2020-2023  润新知