• Gridland(规律)


    Gridland

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Background
    For years, computer scientists have been trying to find efficient solutions to different computing problems. For some of them efficient algorithms are already available, these are the "easy" problems like sorting, evaluating a polynomial or finding the shortest path in a graph. For the "hard" ones only exponential-time algorithms are known. The traveling-salesman problem belongs to this latter group. Given a set of N towns and roads between these towns, the problem is to compute the shortest path allowing a salesman to visit each of the towns once and only once and return to the starting point.

    Problem
    The president of Gridland has hired you to design a program that calculates the length of the shortest traveling-salesman tour for the towns in the country. In Gridland, there is one town at each of the points of a rectangular grid. Roads run from every town in the directions North, Northwest, West, Southwest, South, Southeast, East, and Northeast, provided that there is a neighbouring town in that direction. The distance between neighbouring towns in directions North-South or East-West is 1 unit. The length of the roads is measured by the Euclidean distance. For example, Figure 7 shows 2 * 3-Gridland, i.e., a rectangular grid of dimensions 2 by 3. In 2 * 3-Gridland, the shortest tour has length 6.

    Figure 7: A traveling-salesman tour in 2 * 3-Gridland.

    Input
    The first line contains the number of scenarios.
    For each scenario, the grid dimensions m and n will be given as two integer numbers in a single line, separated by a single blank, satisfying 1 < m < 50 and 1 < n < 50.

    Output The output for each scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. In the next line, print the length of the shortest traveling-salesman tour rounded to two decimal digits. The output for every scenario ends with a blank line.

    Sample Input
    2 2 2 2 3

    Sample Output
    Scenario #1: 4.00
    Scenario #2: 6.00

    题意:给你一个网格,让从一个点出发,访问所有的城市回到起点,规律是如果两个数都是奇数要加0.41;即:a*b-1+sqrt(2.0);否则肯定可以回到起点,直接是a*b;

    c代码:

    #include<iostream>
    #include<algorithm>
    using namespace std;
    #include<cstdio>
    #include<cmath>
    int main(){
    	int T,kase=0;
    	cin>>T;
    	while(T--){
    		int a,b;
    		double ans;
    		cin>>a>>b;
    		if(a&1&&b&1)ans=a*b+0.41;
    		else ans=(double)a*b;
    		printf("Scenario #%d:
    %.2lf
    ",++kase,ans);
    		puts("");
    	}
    	return 0;
    }
    

      python:

    import sys
    
    an=sys.stdin.readline()
    t=an.split();
    n=int(t[0])
    k=0
    while n:
        n-=1
        k+=1
        an=sys.stdin.readline()
        t=an.split();
        a=int(t[0])
        b=int(t[1])
        if (a%2) and (b%2):
            sum=a*b+0.41
        else:
            sum=a*b
        print('Scenario #%d:'%k)
        print("%.2f
    "%sum)
    #真心无奈了,各种出问题,最终发现python的对齐方式这么重要。。。
    

      

    __author__ = 'cuijunyong'
    
    import math
    T = int(raw_input(), 10);
    i = 1
    while i <= T:
        a = raw_input().split();
        print "Scenario #%d:" %i;
        if((int(a[0]) & 1 == 1) and (int(a[1]) & 1 == 1)):
            print "%.2f" %(round((float(a[0])*float(a[1]) + math.sqrt(2) - 1), 2));
        else:
            print "%.2f" %(round((float(a[0])*float(a[1])), 2));
        i += 1;
        print ;
    

      

  • 相关阅读:
    My.NET.ClassLibrary.Note.1
    DesignPattern.Ch12.Facade.Node
    DesignPattern.Ch10.Template Method.Note
    Oracle.sql.Note
    C#.Static Field And Static Constructor.Autocriticism
    DesignPattern.Ch4.Open Closed Principle.Note
    关于n!被整除的问题【算法实现】
    令人费解的编译错误:error C2144: syntax error : 'double' should be preceded by ';' 和 error C3646: ';' : unknown override specifier
    诡异难解决的错误:Windows已在xxx.exe中触发一个断点
    Linux(Ubuntu10.04 )下libxml2的安装以及使用示例
  • 原文地址:https://www.cnblogs.com/handsomecui/p/5126370.html
Copyright © 2020-2023  润新知