• UVA-514 Rails (栈)


      Rails 

    There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

    egin{picture}(6774,3429)(0,-10)
put(1789.500,1357.500){arc{3645.278}{4.7247}...
...tFigFont{14}{16.8}{
mdefault}{mddefault}{updefault}Station}}}}}
end{picture} 

    The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has $N leŸ 1000$ coaches numbered in increasing order $1, 2, dots, N$. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be $a_1. a_2, dots, a_N$. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

    Input 

    The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of $1, 2, dots, N$ The last line of the block contains just 0.

    The last block consists of just one line containing 0.

    Output 

    The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input file. There is no line in the output file corresponding to the last ``null'' block of the input file.

    Sample Input 

    5
    1 2 3 4 5
    5 4 1 2 3
    0
    6
    6 5 4 3 2 1
    0
    0
    

    Sample Output 

    Yes
    No
    
    Yes
    题解:火车进栈;
    代码:
    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstring>
    #include<cmath>
    #include<queue>
    #include<stack>
    #include<vector>
    using namespace std;
    const int INF=0x3f3f3f3f;
    const double PI=acos(-1.0);
    #define mem(x,y) memset(x,y,sizeof(x))
    #define SI(x) scanf("%d",&x)
    #define SL(x) scanf("%lld",&x)
    #define PI(x) printf("%d",x)
    #define PL(x) printf("%lld",x)
    #define P_ printf(" ");
    typedef long long LL;
    const int MAXN=1010;
    int a[MAXN];
    int N;
    bool js(){
    	stack<int>S;
    	int i,j;
    	for(i=1,j=0;i<=N;i++){
    		S.push(i);
    		if(i==a[j]){
    			while(!S.empty()){
    				if(S.top()==a[j]){
    					j++;S.pop();
    				}
    				else break;
    			}
    		}
    	}
    	while(!S.empty()){
    		if(S.top()!=a[j])return false;
    		S.pop();j++;
    	}
    	return true;
    }
    int main(){
    	while(SI(N),N){
    		while(true){
    			SI(a[0]);
    			if(!a[0])break;
    			for(int i=1;i<N;i++)SI(a[i]);
    			if(js())puts("Yes");
    			else puts("No");
    		}
    		puts("");
    	}
    	return 0;
    }
    

      

  • 相关阅读:
    [DOJ练习] 无向图的邻接矩阵表示法验证程序
    [DOJ练习] 求无向图中某顶点的度
    [邻接表形式]有向图的建立与深度,广度遍历
    [DOJ练习] 有向图的邻接表表示法验证程序(两种写法)
    [Java 学习笔记] 异常处理
    [总结]单源最短路(朴素Dijkstra)与最小生成树(Prim,Kruskal)
    时间选择插件jquery.timepickr
    页面值传入后台出现中文乱码
    CheckTreecheckbox树形控件
    JQuery EasyUI DataGrid
  • 原文地址:https://www.cnblogs.com/handsomecui/p/5082348.html
Copyright © 2020-2023  润新知