• poj1742(Coins)


    Description

    People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
    You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

    Input

    The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

    Output

    For each test case output the answer on a single line.

    Sample Input

    3 10
    1 2 4 2 1 1
    2 5
    1 4 2 1
    0 0
    

    Sample Output

    8
    4

    给出每种硬币的币值和数量,求可以组成多少种1~m中的价值。用dp[i]=0或者1表示价值i能否得到,sum[i]表示对于每种硬币,组成价值i需要多少枚。则当dp[j]=0且dp[j-v[i]]=1且sum[j-v[i]]<c[i]时价值j可以得到,具体实现见代码。

    #include <iostream>
    #include <sstream>
    #include <fstream>
    #include <string>
    #include <map>
    #include <vector>
    #include <list>
    #include <set>
    #include <stack>
    #include <queue>
    #include <deque>
    #include <algorithm>
    #include <functional>
    #include <iomanip>
    #include <limits>
    #include <new>
    #include <utility>
    #include <iterator>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <cctype>
    #include <cmath>
    #include <ctime>
    using namespace std;
    typedef long long LL;
    const int INF = 0x3f3f3f3f;
    const double PI = acos(-1.0);
    const double EPS = 1e-8;
    const int MAXN = 110;
    int dx[] = {0, 1, 0, -1}, dy[] = {-1, 0, 1, 0};
    
    int v[110], c[110], dp[100010], sum[100010];
    
    int main()
    {
        int n, m;
        while (scanf("%d%d", &n, &m) == 2 && (n || m))
        {
            for (int i = 0; i < n; ++i)
                scanf("%d", &v[i]);
            for (int i = 0; i < n; ++i)
                scanf("%d", &c[i]);
            memset(dp, 0, sizeof(dp));
            dp[0] = 1;
            int ans = 0;
            for (int i = 0; i < n; ++i)
            {
                memset(sum, 0, sizeof(sum));
                for (int j = v[i]; j <= m; ++j)
                    if (!dp[j] && dp[j-v[i]] && sum[j-v[i]] < c[i])
                    {
                        dp[j] = 1;
                        sum[j] = sum[j-v[i]] + 1;
                        ans++;
                    }
            }
            cout << ans << endl;
        }
        return 0;
    }


  • 相关阅读:
    l1-010
    l1-009
    L1-008修改
    l1-008
    Codeforces Round #406 (Div. 2)
    求N!的长度【数学】 51nod 1058 1130
    51nod 1090 & 1267 【二分简单题】
    Codeforces Round #405 (Div. 2)
    Codeforces Round #404 (Div. 2)
    PAT 天梯赛真题集(L2、L3)
  • 原文地址:https://www.cnblogs.com/godweiyang/p/12203976.html
Copyright © 2020-2023  润新知