• 1007 Maximum Subsequence Sum


    Given a sequence of K integers { N1​​, N2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:

    10
    -10 1 2 3 4 -5 -23 3 7 -21
    

    Sample Output:

    10 1 4



    这破题做的。JAVA O(N)算法都超时。mlgb
    思路就是贪心。

    import java.util.Scanner;
    
    public class Main{
        static int Nums[];
        static int N;
        static int Max = 0;
        static int start;
        static int end;
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            N = sc.nextInt();
            Nums = new int[N];
            int sum = 0;//当前总数
            int sign = 0;
            for(int i=0,j=0;i<N;i++) {
                Nums[i] = sc.nextInt();
                sum+=Nums[i];
                if(sum>Max) {
                    Max=sum;
                    start=Nums[j];
                    end=Nums[i];
                }
                else if(sum<0) {
                    j=i+1;
                    sum=0;
                    sign++;
                }
                else if(sum==0&&Max==0) {
                    start=0;
                    end=0;
                }
            }
            if(sign==N) {
                start=Nums[0];
                end=Nums[N-1];
            }
            sc.close();
            System.out.println(Max+" "+start+" "+end);
        }
    }

    用C++改写提交即可

  • 相关阅读:
    ArcGIS安装中模块不能注册问题的解决办法
    BW一些关于DTP的一些链接
    HR一个奖金模拟试算的程序,仅供参考
    SD关于SD的业务的锁定的几个tCODE
    ABAP如何在abap中使用日志管理
    HR一个员工的所有主数据(PA*)克隆到一个新员工的程序代码
    LSMW--一个中文介绍的摘抄
    MM物料重新过账的代码摘抄
    ABAP如何创建和使用sap的号码范围对象
    BDC Program to Upload Material Master Data (MM01)
  • 原文地址:https://www.cnblogs.com/godoforange/p/10908580.html
Copyright © 2020-2023  润新知