• PTA 03-树2 List Leaves (25分)


    题目地址 https://pta.patest.cn/pta/test/16/exam/4/question/666

    5-4 List Leaves   (25分)

    Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer NN (le 1010) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1N1. Then NNlines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

    Output Specification:

    For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

    Sample Input:

    8
    1 -
    - -
    0 -
    2 7
    - -
    - -
    5 -
    4 6
    

    Sample Output:

    4 1 5


    大部分代码都是在做数据结构,其它的,就是简单的层序遍历
    /*
    评测结果
    时间	结果	得分	题目	编译器	用时(ms)	内存(MB)	用户
    2017-07-08 15:59	答案正确	25	5-4	gcc	2	1	
    测试点结果
    测试点	结果	得分/满分	用时(ms)	内存(MB)
    测试点1	答案正确	13/13	1	1
    测试点2	答案正确	5/5	2	1
    测试点3	答案正确	1/1	1	1
    测试点4	答案正确	5/5	2	1
    测试点5	答案正确	1/1	1	1
    */
    #include<stdio.h>
    #include<stdlib.h>
    #define MAXLEN 10
    struct treenode{
    	int lc;
    	int rc;
    	int isLeaf;
    	int father;
    };
    
    typedef struct tree{
    	struct treenode nodes[MAXLEN];
    	int root;
    	int length;
    }*ptrTree;
    
    typedef struct queue{
    	int data[MAXLEN];
    	int front;
    	int rear;
    }*Que;
    
    Que CreateQueue()
    {	
    	Que temp;
    	temp=(Que)malloc(sizeof(struct queue));
    	temp->front=0;
    	temp->rear=0;
    	return temp;	
    }
    
    void EnQueue(Que Q,int item)
    {
    	if((Q->rear+1)%MAXLEN == Q->front)
    		printf("Queue is full!");
    	Q->rear=(Q->rear+1)%MAXLEN;
    	Q->data[Q->rear]=item;
    }
    
    int DeQueue(Que Q)
    {
    	if(Q->front==Q->rear){
    		printf("Queue is Empty!");
    		return -1;
    	}
    	Q->front=(Q->front+1)%MAXLEN;
    	return Q->data[Q->front];
    }
    
    int IsQueueEmpty(Que Q)
    {
    	return Q->front==Q->rear;
    }
    
    ptrTree CreateTree()
    {
    	int i;
    	ptrTree temp;
    	temp=(ptrTree)malloc(sizeof(struct tree));
    	for(i=0;i<MAXLEN;i++)
    		temp->nodes[i].father=-1;
    	return temp;
    	
    }
    
    void DestroyQueue(Que Q)
    {
    	free(Q);
    }
    
    void DestroyTree(ptrTree T)
    {
    	free(T);
    }
    
    void Input(ptrTree T)
    {
    	int i,k,len;
    	scanf("%d",&len);
    	getchar();//skip a 
    
    	T->length=len;
    	for(i=0;i<len;i++)
    	{
    		T->nodes[i].lc=getchar()-'0';
    		getchar();//skip a space
    		T->nodes[i].rc=getchar()-'0';
    		getchar();//skip a 
    
    		
    		if(T->nodes[i].lc>=0)
    			T->nodes[T->nodes[i].lc].father=i;
    		if(T->nodes[i].rc>=0)
    			T->nodes[T->nodes[i].rc].father=i;
    			
    		if(T->nodes[i].lc<0 && T->nodes[i].rc<0)
    			T->nodes[i].isLeaf=1;
    	}
    	
    	for(i=0;i<len;i++){
    		if(T->nodes[i].father<0){
    			T->root=i;
    			break;
    		}
    	}
    }
    
    
    void Process(ptrTree T,Que Q)
    {
    	EnQueue(Q,T->root);
    	while(!IsQueueEmpty(Q))
    	{	
    		int i;
    		i=DeQueue(Q);
    		if(T->nodes[i].isLeaf==1)
    			printf("%d",i);
    		else {
    			if(T->nodes[i].lc>=0)
    				EnQueue(Q,T->nodes[i].lc);
    			if(T->nodes[i].rc>=0)
    				EnQueue(Q,T->nodes[i].rc);
    		}
    		if(T->nodes[i].isLeaf==1 && !IsQueueEmpty(Q))
    			printf(" ");
    	}
    }
    
    int main()
    {
    	Que Q=CreateQueue();
    	ptrTree T=CreateTree();
    	Input(T);
    	Process(T,Q);
    	return 0;
    }
    

      

  • 相关阅读:
    【(高职专科组)第十一届蓝桥杯省模拟赛答案】给定一个数列,请问找出元素之间最大的元素距离。
    【(高职专科组)第十一届蓝桥杯省模拟赛答案】给定一个数列,请问数列中最长的递增序列有多长。
    POJ 2391 二分+最大流
    HDU 4529 状压dp
    NYOJ 747贪心+dp
    NYOJ 745 dp
    HDU 2686 / NYOJ 61 DP
    HDU 4313树形DP
    HDU 4303 树形DP
    POJ 2342 树形DP
  • 原文地址:https://www.cnblogs.com/gk2017/p/7140544.html
Copyright © 2020-2023  润新知