• hdu 1025 Constructing Roads In JGShining's Kingdom【即求最长上升子序列】


    DP(呃,两边不交叉修路的那道。。。)

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1025

    Constructing Roads In JGShining's Kingdom

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 9069    Accepted Submission(s): 2579


    Problem Description
    JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

    Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

    With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

    Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

    The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

    But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

    For example, the roads in Figure I are forbidden.



    In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
     

    Input
    Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
     

    Output
    For each test case, output the result in the form of sample. 
    You should tell JGShining what's the maximal number of road(s) can be built. 
     

    Sample Input
    2 1 2 2 1 3 1 2 2 3 3 1
     

    Sample Output
    Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
    Hint
    Huge input, scanf is recommended.
     

    Author
    JGShining(极光炫影)
    题目就是要我们两边不交叉修路,即求最长上升子序列,DP入门题目。。。
     
    //Dp问题:求最长上升子序列
    //思路:1 状态转移; 2二分查找;
    
    //AC 468MS	612K	664 B by C++
    #include<cstdio>
    #include<iostream>
    using namespace std;
    
    int a[500005],dp[50005];
    
    int main()
    {
    	int n,i,right,mid,left,test=0,len;
    	int p,r;
    	while(cin>>n)
    	{
    		for(i=0;i<n;i++)
    		{
    			cin>>p>>r;
    			a[p]=r;
    		}
    		len=1;
    		dp[1]=a[1];
    		for(i=2;i<=n;i++)
    		{
    			right=0;
    			left=len;
    			while(right<=left)
    			{
    				mid=(right+left)/2;
    				a[i] > dp[mid] ? right=mid+1 : left=mid-1;
    			}
    			dp[right]=a[i];
    			if(right>len)
    				len++;
    		}
    		if(len==1)
    			printf("Case %d:\nMy king, at most 1 road can be built.\n\n",++test);
    		else
    			printf("Case %d:\nMy king, at most %d roads can be built.\n\n",++test,len);
    	}
    	return 0;
    }



  • 相关阅读:
    面试生信工程师2
    R语言矩阵相关性计算及其可视化?
    PCA方差解释比例求解与绘图?
    MySQL 练习
    oracle高级数据查询技术
    Oracle安全管理
    基本查询语句
    管理表
    oracle PL/SQL高级编程
    oracle视图与索引
  • 原文地址:https://www.cnblogs.com/freezhan/p/2974248.html
Copyright © 2020-2023  润新知