• 1051 Wooden Sticks


    http://acm.hdu.edu.cn/showproblem.php?pid=1051

    Wooden Sticks

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 4694    Accepted Submission(s): 1933


    Problem Description
    There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

    (a) The setup time for the first wooden stick is 1 minute.
    (b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

    You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
     
    Input
    The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
     
    Output
    The output should contain the minimum setup time in minutes, one per line.
     
    Sample Input
    3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
     
    Sample Output
    2 1 3

    #include<iostream>
    #include<algorithm>
    using namespace std;
    typedef struct Node
    {
     int len,w;
    }Node;
    Node p[5010];
    int f[5010];

    bool cmp(Node a,Node b)
    {
     if(a.len!=b.len) return a.len<b.len;
     return a.w<b.w;
    }

    int main()
    {
     int t,i,j,n;
     cin>>t;
     while(t--)
     {
      cin>>n;
      for(i=0;i<n;i++)
       cin>>p[i].len>>p[i].w;
      sort(p,p+n,cmp);
      int cnt=0;
      for(i=0;i<n;i++) f[i]=1;
      for(i=1;i<n;i++)
       for(j=0;j<i;j++)
        if(p[j].w>p[i].w&&f[i]<f[j]+1) f[i]=f[j]+1;
        int sum=0;
        for(i=0;i<n;i++) if(f[i]>sum) sum=f[i];
        cout<<sum<<endl;
     }
     return 0;
    }

     
  • 相关阅读:
    LOJ#3212. 「CSP-S 2019」划分
    矩阵乘法
    SSF信息社团4月训练题目整理
    AtCoder Regular Contest 116
    SSF信息社团3月训练题目整理
    Codeforces Round #704 (Div. 2)
    SSF信息社团寒假训练题目整理(三)
    关于 zzt 得 0.8 分这件事
    Luogu P7244 章节划分
    SSF信息社团寒假训练题目整理(二)
  • 原文地址:https://www.cnblogs.com/forgood/p/2237791.html
Copyright © 2020-2023  润新知