• Big Chocolate


    Big Chocolate

    题目链接:http://acm.hust.edu.cn/vjudge/problem/visitOriginUrl.action?id=19127

    Big Chocolate

    Mohammad has recently visited Switzerland . As he loves his friends very much, he decided to buy some chocolate for them, but as this fine chocolate is very expensive(You know Mohammad is a little BIT stingy!), he could only afford buying one chocolate, albeit a very big one (part of it can be seen in figure 1) for all of them as a souvenir. Now, he wants to give each of his friends exactly one part of this chocolate and as he believes all human beings are equal (!), he wants to split it into equal parts.

    The chocolate is an rectangle constructed from  unit-sized squares. You can assume that Mohammad has also  friends waiting to receive their piece of chocolate.

    To split the chocolate, Mohammad can cut it in vertical or horizontal direction (through the lines that separate the squares). Then, he should do the same with each part separately until he reaches  unit size pieces of chocolate. Unfortunately, because he is a little lazy, he wants to use the minimum number of cuts required to accomplish this task.

    Your goal is to tell him the minimum number of cuts needed to split all of the chocolate squares apart.

     

    Figure 1. Mohammad’s chocolate

     

    The Input

    The input consists of several test cases. In each line of input, there are two integers , the number of rows in the chocolate and , the number of columns in the chocolate. The input should be processed until end of file is encountered.

    The Output

    For each line of input, your program should produce one line of output containing an integer indicating the minimum number of cuts needed to split the entire chocolate into unit size pieces.

    Sample Input

    2 2

    1 1

    1 5

     

    Sample Output

    3

    0

    4

    题意:将一块M*N的巧克力切成单位大小的巧克力;求出削减所有的巧克力块所需的最小刀数的数量。

    分析:

    如果是正方形(M=N)不管如何切都是一样的,当是长方形时如M>N就先切M-1刀使它变成M块N*1的巧克力,

    再将这些巧克力切成单位大小的巧克力。

    #include<iostream>
     #include<cstdio>
      using namespace std;
      int main()
      {
      int n,m,cut;
      while(scanf("%d%d",&n,&m)!=EOF)
      {    cut=0;
     if(n>m)
     cut=n*(m-1)+n-1;
     else cut=m*(n-1)+m-1;
     cout<<cut<<endl;
    }
     return 0;
     }
    
  • 相关阅读:
    AMQP 介绍
    JMS 介绍
    SpringCloud 入门实战(12)--Zipkin(2)--安装使用
    SpringCloud 入门实战(11)--Zipkin(1)--简介
    Kafka 入门实战(3)--SpringBoot 整合 Kafka
    跨域访问方法介绍(9)--nginx 反向代理
    跨域访问方法介绍(8)--使用 WebSocket
    个人网站建好啦!
    Spring Boot配置Slf4j + log4j2
    SpringBoot 解决跨域,3种解决方案
  • 原文地址:https://www.cnblogs.com/fenhong/p/4656207.html
Copyright © 2020-2023  润新知