• L


    Description

    The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.        
                    

    Input

    Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.        
                    

    Output

    For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.        
                    

    Sample Input

    2
    3 5 7 15
    6 4 10296 936 1287 792 1
                    

    Sample Output

    105
    10296
     
     
    如下为一般方法写的代码
    #include<iostream>
    using namespace std;
    int s[500];
    __int64 x;
    int cmp ( const void *a , const void *b ) 
    {  
        return *(int *)b - *(int *)a; 
    }
    void f(int s[],int n)
    {
        int p=1;
        bool flag;
        while(1){
            flag=true;
            x=s[0]*p;
            for(int i=1;i<n;i++){
                if(x%s[i]!=0){
                    flag=false;
                    break;
                }
            }
            if(flag==true)break;
            p++;
        }
        cout<<x<<endl;
    }
    int main()
    {
        int n;
        cin>>n;
        while(n--){
            int a;
            cin>>a;
            for(int i=0;i<a;i++)cin>>s[i];
            qsort(s,a,sizeof(s[0]),cmp);
            f(s,a);
        }
        return 0;
    }


    如下为运用辗转相除法写的代码

    #include<iostream>
    using namespace std;
    int s[500];
    __int64 x,y;
    int g(int a,int b)      
    {
        int i,t;
        y=a*b;
        if(a<b){
            t=a;
            a=b;
            b=t;
        }
        while(b){
            t=b;
            b=a%b;
            a=t;
        }
        return y/a;    
    }
    void f(int s[],int n)
    {
        x=s[0];
        for(int i=1;i<n;i++){
            x=g(s[i],x);
        }
        cout<<x<<endl;
    }
    int main()
    {
        int n;
        cin>>n;
        while(n--){
            int a;
            cin>>a;
            for(int i=0;i<a;i++)cin>>s[i];
            f(s,a);
        }
        //system("pause");
        return 0;
    }
  • 相关阅读:
    【原】基础篇:第一篇,本节主要向大家介绍Ext的最基础的话题
    【原】基础篇:第七篇,Ext组件系列之label组件的基本用法
    【原】基础篇:第三篇,常用的一些Ext方法
    框架
    【原】基础篇:第六篇,Ext组件系列之button组件的基本用法
    序列化
    【原】基础篇:第四篇,Ext中有两个很重要的方法,一个是decode;一个是encode.
    Arrays.asList详解
    JSP页面导出CSV查询结果
    Log的重要性
  • 原文地址:https://www.cnblogs.com/farewell-farewell/p/5186649.html
Copyright © 2020-2023  润新知