路由调试
设备基础设置
- display version
- clock timezone Local add 08: 00: 00
Local
字段为当前地区的时区名称, add
是东区,minus
是西区
- clock datetime 16: 40: 00 2019-07-18
display clock
显示时间
- system-view
进入系统视图,可简写为sys
<huawei >
用户视图 显示、查询
[huawei]
系统视图 修改
- 注意修改路由名称要在系统视图
[Huawei]sysname R1
-
让相连的端口成组,方便批量设置
int range g1/0/1 to g1/0/16 -
配置登陆标语信息来进行提示或进行登陆警告
header shell information "Let's fuck the world!."
- 设置console 密码
[R1]user-interface console 0
[R1-ui-console0]authentication-mode password
[R1-ui-console0]set authentication password cipher XXXXX
- 设置空闲超时时间为20分钟(默认为10)
[R1-ui-console0] idle-timeout 20 0
- 查看和撤销该口的设置
[R1] display this
[R1] undo something
- 配置路由ip
[R1]interface GigabitEthernet 0/0/0
[R1-GigabitEthernet0/0/0]ip address 10.0.13.1 24
[R1-GigabitEthernet0/0/0]description This interface connects to R3-G0/0/0
- 查看接口信息。
[R1]display interface GigabitEthernet0/0/0
[R1]display interface
[R1]display ip interface
[R1]display ip routing-table
[R1]display stp
后接brief
可以保留概要
交换机
配置stp
- 启用
stp enable
- 修改模式
stp mode stp
- 修改桥优先级,控制选举根桥
stp root primary
stp root secondary
stp priority 4096
stp priority 8192
- 修改端口优先级,控制选举根端口和指定端口
进入端口设置
stp port priority 16
stp port priority 32
stp cost 10000
默认20000
配置rstp
- 启用rstp
stp mode rstp
- 配置边缘端口
stp edged-port enable
- 配置BPDU保护功能
stp bpdu-protection
- 配置环路保护
stp loop-protection
路由
- 静态路由
目的ip地址 | 掩码长度 | 指定下一跳ip地址 | |
---|---|---|---|
ip route-static | 10.0.13.0 | 24 | 10.0.23.3 |
- 备份静态路由
ip route-static 10.0.13.0 255.255.255.0 10.0.12.1 preference 80
ip route-static 10.0.3.0 24 10.0.12.1 preference 80
即给另一条较远的路也设好路径,但是优先级较低,默认60,
当有两条路可以到同一ip地址,只显示优先级最高(数字最低)的那一条
- 缺省路由
[R1] | 目的ip地址 | 掩码长度 | 指定下一跳ip地址 |
---|---|---|---|
ip route-static | 0.0.0.0 | 0 | 10.0.13.3 |
0表示任何1-255的任意数字
- 备份缺省路由
[R1]ip route-static 0.0.0.0 010.0.12.2 preference 80
[R3]ip route-static 10.0.12.0.2410.0.23.2 preference 80
缺省路由需要在对应路由设置回来的路
- loopback
管理员可以用该地址对这台路由器远程登录
地址通常指定为32位掩码,目的是为了节约地址资源
还可以做为路由器动态路由协议OSPF、BGP的router id,做为此路由器的唯一表示,并要求在整个自治系统内唯一
interface loopback0