• 1124 Raffle for Weibo Followers (20 分)


    John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

    Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

    Output Specification:

    For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

    Sample Input 1:

    9 3 2
    Imgonnawin!
    PickMe
    PickMeMeMeee
    LookHere
    Imgonnawin!
    TryAgainAgain
    TryAgainAgain
    Imgonnawin!
    TryAgainAgain
     

    Sample Output 1:

    PickMe
    Imgonnawin!
    TryAgainAgain
     

    Sample Input 2:

    2 3 5
    Imgonnawin!
    PickMe
     

    Sample Output 2:

    Keep going...
     
     
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=1010;
    map<string,int> mp;
    
    int main(){
        int m,n,s;
        cin>>m>>n>>s;
        bool flag=false;
        for(int i=1;i<=m;i++){
            string str;
            cin>>str;
            if(mp[str]==1){
                s++;
            }
            if(mp[str]==0&&i==s){
                mp[str]=1;
                cout<<str<<endl;
                flag=true;
                s+=n;
            }
        }
        if(flag==false){
            cout<<"Keep going..."<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Delphi 2005 以上版本GIF动画播放设置
    WIN7中盾牌的编程-DELPHI
    Delphi中ComPort通信中的数据处理
    【ZJOI2008】树的统计(树链剖分)
    【CJOJ2440】大话西游(树链剖分)
    【洛谷3384】【模板】树链剖分
    【NOI2004】郁闷的出纳员(splay)
    【HNOI2004】宠物收养所(splay)
    【HNOI 2002 】营业额统计(splay)
    【Tyvj 1728】普通平衡树
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14464886.html
Copyright © 2020-2023  润新知