• POJ1028 Web Navigation



     

    Web Navigation
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 23885   Accepted: 10653

    Description

    Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.
    The following commands need to be supported:
    BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.
    FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.
    VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.
    QUIT: Quit the browser.
    Assume that the browser initially loads the web page at the URL http://www.acm.org/

    Input

    Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

    Output

    For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

    Sample Input

    VISIT http://acm.ashland.edu/
    VISIT http://acm.baylor.edu/acmicpc/
    BACK
    BACK
    BACK
    FORWARD
    VISIT http://www.ibm.com/
    BACK
    BACK
    FORWARD
    FORWARD
    FORWARD
    QUIT

    Sample Output

    http://acm.ashland.edu/
    http://acm.baylor.edu/acmicpc/
    http://acm.ashland.edu/
    http://www.acm.org/
    Ignored
    http://acm.ashland.edu/
    http://www.ibm.com/
    http://acm.ashland.edu/
    http://www.acm.org/
    http://acm.ashland.edu/
    http://www.ibm.com/
    Ignored

    /*
       功能Function Description:     栈的应用  POJ-1028   TOJ-1196
       开发环境Environment:          DEV C++ 4.9.9.1
       技术特点Technique:
       版本Version:
       作者Author:                   可笑痴狂
       日期Date:                 	 20120802
       备注Notes:                    栈也可以存储定义string类型
       题目来源:
    */
    #include<iostream>
    #include<string>
    #include<stack>
    using namespace std;
    
    int main()
    {
    	stack<string> s1,s2;
    	string cmd,URL;
    	s1.push("http://www.acm.org/");
    	while(cin>>cmd)
    	{
    		if(cmd[0]=='Q')
    			break;
    		else if(cmd[0]=='V')
    		{
    			cin>>URL;
    			s1.push(URL);
    			cout<<URL<<endl;
    			while(!s2.empty())       //注意这里要将s2清空
    				s2.pop();
    		}
    		else if(cmd[0]=='B')
    		{
    			if(s1.size()>1)          //注意这里是大于1,即必须有两个或两个以上元素才行,
    			{						//因为s1的栈顶元素是当前访问的页面,后退一步必须返回到当前栈顶的下一个元素		
    				s2.push(s1.top());				
    				s1.pop();
    				cout<<s1.top()<<endl;
    			}
    			else
    				cout<<"Ignored"<<endl;
    		}
    		else
    		{
    			if(!s2.empty())
    			{	
    				s1.push(s2.top());
    				cout<<s2.top()<<endl;
    				s2.pop();
    			}
    			else
    				cout<<"Ignored"<<endl;
    		}
    	}
    	return 0;
    }
    
    功不成,身已退
  • 相关阅读:
    【转】 Ubuntu安装jdk报错:-bash /usr/.../java:No such file or directroy
    sudo 出现unable to resolve host 解决方法
    C99 布尔
    面向对象?
    高斯消元
    白皮 Chapter 2
    白皮 Chapter 1
    开启暑假新生活( •̀ ω •́ )
    [vijos P1040] 高精度乘法
    [SCOI2007] 修车
  • 原文地址:https://www.cnblogs.com/dongsheng/p/2619314.html
Copyright © 2020-2023  润新知