• PAT 1036 Boys vs Girls (25 分)


    1036 Boys vs Girls (25 分)
     

    This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's namegenderID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F(female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF​​gradeM​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

    Sample Input 1:

    3
    Joe M Math990112 89
    Mike M CS991301 100
    Mary F EE990830 95
    

    Sample Output 1:

    Mary EE990830
    Joe Math990112
    6
    

    Sample Input 2:

    1
    Jean M AA980920 60
    

    Sample Output 2:

    Absent
    Jean AA980920
    NA


    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    
    
    int main(){
        int t;
        cin >> t;
        int mannum = 999;
        string manname = "man";
        string manid = "";
        int fenum = -1;
        string fename = "feman";
        string feid = "";
        while(t--){
            string s1,s2,s3;
            int grade;
            cin >> s1 >> s2 >> s3 >> grade;
            if(s2 == "M"){
                if(grade < mannum){
                    manname = s1;
                    manid = s3;
                    mannum = grade;
                }
            }
            else{
                if(grade > fenum){
                    fename = s1;
                    feid = s3;
                    fenum = grade;
                }
            }
        }
        if(fename != "feman"){
            cout << fename << " " << feid << endl;
        }
        else cout << "Absent" << endl;
        if(manname != "man"){
            cout << manname << " " << manid << endl;
        }
        else cout << "Absent" << endl;
        
        if(fename != "feman"&&manname != "man"){
            cout << fenum - mannum;
        }
        else cout << "NA";
        
        return 0;
    } 

    ez

  • 相关阅读:
    openstack-ntp时间同步服务
    如何将icon图标库引入自己的项目中
    微信小程序实现滑动tab切换和点击tab切换并显示相应的数据(附源代码)
    微信小程序分享至朋友圈的方法
    微信小程序--分享功能
    mpvue-新建页面、页面跳转、自适应单位
    微信小程序mpvue-动态改变navigationBarTitleText值
    mpvue中使用flyjs全局拦截
    H5 布局 -- 让容器充满屏幕高度或自适应剩余高度
    使用mpvue开发小程序如何定义全局变量
  • 原文地址:https://www.cnblogs.com/cunyusup/p/11455757.html
Copyright © 2020-2023  润新知