• PAT 1003 Emergency


    1003 Emergency (25 分)
     

    As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

    Input Specification:

    Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤) - the number of cities (and the cities are numbered from 0 to N1), M - the number of roads, C1​​ and C2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1​​, c2​​and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1​​ to C2​​.

    Output Specification:

    For each test case, print in one line two numbers: the number of different shortest paths between C1​​ and C2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

    Sample Input:

    5 6 0 2
    1 2 1 5 3
    0 1 1
    0 2 2
    0 3 1
    1 2 1
    2 4 1
    3 4 1
    

    Sample Output:

    2 4

    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    int mp[505][505] = {0};
    int vis[505] = {0};
    int chenshi,daolu,start,over;
    int val[505] = {0};
    int cnt=0;
    int minval = INT_MAX;
    int maxnum = INT_MIN;
    
    void dfs(int x,int nowval,int nownum){
        if(x == over){
            if(nowval < minval){minval = nowval;cnt=1;maxnum = nownum;}
            else if(nowval == minval){cnt++;maxnum = max(maxnum,nownum);}
            return;
        }
    
        for(int i=0;i < chenshi;i++){
            if(!vis[i]&&mp[x][i]){
                vis[i] = 1;
                dfs(i,nowval+mp[x][i],nownum+val[i]);
                vis[i] = 0;
            }
        }
    
        return;
    }
    
    
    
    int main(){
    
        cin >> chenshi >> daolu >> start >> over;
        vis[start] = 1;
    
        for(int i=0;i < chenshi;i++) cin >> val[i];
    
        while(daolu--){
            int i,j,n;
            cin >> i >> j;cin >> n;
            mp[i][j] = mp[j][i] = n;
        }
    
        dfs(start,0,val[start]);
        cout << cnt << " " << maxnum;
    
        return 0;
    }

    一发入魂,我太牛逼了。

    复习了图的dfs,一开始漏掉了是无向图的条件。

  • 相关阅读:
    多任务GUI窗口系统(类window,有源码,支持汉字显示、顶层、非矩形和透明窗口)gicell源码
    怎样判断treeview当前节点为treeview显示出来的第一个节点和最后一个节点?
    用 dbgrid 或 dbgrideh 如何让所显示数据自动滚动
    vue路由懒加载及组件懒加载
    vue 中使用rem布局
    纯css实现移动端横向滑动列表&&overflow:atuo;隐藏滚动条
    分布式一致性算法Raft
    HDU_1753 大明A+B
    POJ——3630 Phone List
    HDU_2647 Reward (拓扑排序)
  • 原文地址:https://www.cnblogs.com/cunyusup/p/10674482.html
Copyright © 2020-2023  润新知