• Average is not Fast Enough!(格式化输入输出)


    Average is not Fast Enough!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2354    Accepted Submission(s): 923


    Problem Description
    A relay is a race for two or more teams of runners. Each member of a team runs one section of the race. Your task is to help to evaluate the results of a relay race.

    You have to process several teams. For each team you are given a list with the running times for every section of the race. You are to compute the average time per kilometer over the whole distance. That's easy, isn't it? 
    So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm participated e.g. at the "SOLA" relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after the contest is over.
     

    Input
    The first line of the input specifies the number of sections n followed by the total distance of the relay d in kilometers. You may safely assume that 1 <= n <= 20 and 0.0 < d < 200.0. Every following line gives information about one team: the team number t (an integer, right-justified in a field of width 3) is followed by the n results for each section, separated by a single space. These running times are given in the format "h:mm:ss" with integer numbers for the hours, minutes and seconds, respectively. In the special case of a runner being disqualified, the running time will be denoted by "-:--:--". Finally, the data on every line is terminated by a newline character. Input is terminated by EOF.
     

    Output
    For each team output exactly one line giving the team's number t right aligned in a field of width 3, and the average time for this team rounded to whole seconds in the format "m:ss". If at least one of the team's runners has been disqualified, output "-" instead. Adhere to the sample output for the exact format of presentation.
     

    Sample Input
    2 12.5 5 0:23:21 0:25:01 42 0:23:32 -:--:-- 7 0:33:20 0:41:35
     

    Sample Output
    5: 3:52 min/km 42: - 7: 6:00 min/km
     

    Source
     
    #include <iostream>
    #include <cstdio>
    using namespace std;
    
    int main()
    {
        int n, t, h, m, s, tot;
        double d;
        bool flag;
        scanf("%d %lf", &n, &d);
        while(cin >> t)
        {
            flag = 1;
            tot = 0;
            for(int i = 0; i < n; i++)
            {
                char ch1;
                cin >> ch1;
                if(ch1 == '-')
                {
                    cin >> ch1 >> ch1 >> ch1 >> ch1 >> ch1 >> ch1;
                    flag = 0;
                    continue;
                }
                else
                {
                    scanf("%*c%d%*c%d", &m, &s);
                    tot += (s + m*60 + (ch1 - '0')*3600);
                }
            }
            if(!flag) printf("%3d: -\n", t); //3位的宽度
            else
            {
                int ave = 1.0*tot / d + 0.5; //四舍五入的方法
                m = ave/60;
                s = ave%60;
                printf("%3d: %d:%02d min/km\n", t, m, s); //注意秒的输出:%02d
            }
        }
        return 0;
    }
    


  • 相关阅读:
    谈谈对程序猿的管理
    OFMessageDecoder 分析
    [LeetCode-21]Construct Binary Tree from Preorder and Inorder Traversal
    leetcode第一刷_Rotate Image
    [二次开发]dede文章页面怎样显示作者的头像
    MapReduceTopK TreeMap
    安卓3d引擎
    LeetCode::Sort List 具体分析
    杨帆之工作日志-2014.6.24
    CF1109F Sasha and Algorithm of Silence's Sounds
  • 原文地址:https://www.cnblogs.com/cszlg/p/2910562.html
Copyright © 2020-2023  润新知