• 2018HDU多校训练-3-Problem F. Grab The Tree


    Little Q and Little T are playing a game on a tree. There are n vertices on the tree, labeled by 1,2,...,n , connected by n1 bidirectional edges. The i -th vertex has the value of wi .
    In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between x and y , he can't grab both x and y . After Q's move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
    The final score of each player is the bitwise XOR sum of his choosen vertices' value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.
     
    Input
    The first line of the input contains an integer T(1T20) , denoting the number of test cases.
    In each test case, there is one integer n(1n100000) in the first line, denoting the number of vertices.
    In the next line, there are n integers w1,w2,...,wn(1wi109) , denoting the value of each vertex.
    For the next n1 lines, each line contains two integers u and v , denoting a bidirectional edge between vertex u and v .
     
    Output
    For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.
     
    Sample Input
    1 3 2 2 2 1 2 1 3
     
    Sample Output
    Q
    题解:由于是求异或,我们只需考虑每一位上的 1 的个数即可,比如:对于最高位,如果为偶数,那么小Q只需选一个或者不选即可那么小Q,小T最后该位上的数是相同的,如果为奇数,小Q选一个为必胜,因为小Q就选这一个,剩下都给小T,小T的最终结果必定小于小Q, 因此,我们只需要对每一位上的1的个数加一遍,如果有出现奇数个,则Q必胜,否者平局;
    参考代码为:
     
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=1e5+5;
    int w[maxn],u[maxn],v[maxn];
    int main()
    {
    	ios::sync_with_stdio(false);
    	cin.tie(0);
    	
    	int T,n;
    	cin>>T;
    	while(T--)
    	{
    		cin>>n;
    		bool flag=false;
    		for(int i=1;i<=n;i++) cin>>w[i];
    		for(int i=1;i<n;i++) cin>>u[i]>>v[i];
    		for(int i=0;i<32;i++)
    		{
    			int cnt=0;
    			for(int i=1;i<=n;i++)
    			{
    				if(w[i]&1) cnt++;
    				w[i]>>=1;
    			}
    			if(cnt & 1) 
    			{
    				cout<<"Q"<<endl;
    				flag=true;
    				break;
    			}
    		}
    		if(!flag) cout<<"D"<<endl;	
    	}
    	
    	return 0;
    }
    

      

  • 相关阅读:
    Linux之redis-cluster(集群配置)
    MariaDB主从复制,redis发布订阅,持久化,以及主从同步
    Vue之添加全局变量
    Linux之nginx入门
    Linux中python3,django,redis以及mariab的安装
    Linux系统优化及基础命令
    linux基本命令
    Linux常用命令大全
    Flask之项目配置,目录构建,闪现
    C语言II博客作业04
  • 原文地址:https://www.cnblogs.com/csushl/p/9398451.html
Copyright © 2020-2023  润新知