• hdu-1027




    Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess." 

    "Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......" 
    Can you help Ignatius to solve this problem? 
    InputThe input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file. 
    OutputFor each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number. 
    Sample Input
    6 4
    11 8
    Sample Output
    1 2 3 5 6 4
    1 2 3 4 5 6 7 9 8 11 10

    题解:就是求最小排列(字典序)。想到刚学的algorithm中的next_permutation();很简单就AC了。

    AC代码为:

    #include<cstdio>
    #include<iostream>
    #include<algorithm>
    #include<cstring>
    using namespace std;


    int a[1005];


    int main()
    {
    int N,M;


    while(~scanf("%d%d",&N,&M))
    {
    memset(a,0,sizeof(a));

    for(int i=1;i<=N;i++)
    a[i]=i;

    while(--M)
    {
    next_permutation(a+1,a+N+1);
    }

    for(int i=1;i<N;i++)
    printf("%d ",a[i]);
    printf("%d ",a[N]);
    }

    return 0;
    }


  • 相关阅读:
    3、Linux 针对某一个特定用户、单一文件或者目录进行r,w,x的权限设置
    8、shell 打印实时时间日志
    35、shell 的日志不输出到终端
    34、Linux下几种文件传输命令 sz rz sftp scp
    33、umount: /storage: target is busy
    32、Device or resource busy故障处理
    30、终端不打印输出;判断命令是否执行成功;
    29、tar 命令压缩时报错 tar: Removing leading `/' from member names
    28、awk 截取字符串
    27、在脚本里面使用ssh 和 awk 时
  • 原文地址:https://www.cnblogs.com/csushl/p/9386634.html
Copyright © 2020-2023  润新知