• HDU-3577-------Fast Arrrangement


    Chinese always have the railway tickets problem because of its' huge amount of passangers and stations. Now goverment need you to develop a new tickets query system. 
    One train can just take k passangers. And each passanger can just buy one ticket from station a to station b. Each train cannot take more passangers any time. The one who buy the ticket earlier which can be sold will always get the ticket. 
    InputThe input contains servel test cases. The first line is the case number. In each test case: 
    The first line contains just one number k( 1 ≤ k ≤ 1000 ) and Q( 1 ≤ Q ≤ 100000 ) 
    The following lines, each line contains two integers a and b, ( 1 ≤ a < b ≤ 1000000 ), indicate a query. 
    Huge Input, scanf recommanded.OutputFor each test case, output three lines: 
    Output the case number in the first line. 
    If the ith query can be satisfied, output i. i starting from 1. output an blank-space after each number. 
    Output a blank line after each test case.Sample Input
    1
    3 6
    1 6
    1 6
    3 4
    1 5
    1 2
    2 4
    Sample Output
    Case 1:
    1 2 3 5 

    题解:线段树区间最大值问题,判断该区间最大值是否大于等于K,判断是否可以乘坐

    AC代码为:


    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    using namespace std;
    const int maxn=1e6+10;
    int k,q;


    struct node{
    int l,r,num,tag;
    } tree[maxn<<2];


    int max(int a,int b)
    {
    return a>b? a:b;
    }


    void build(int k,int l,int r)
    {
    tree[k].l=l,tree[k].r=r;
    tree[k].num=0,tree[k].tag=0;
    if(l==r) return ;
    int mid=(l+r)>>1;
    build(k<<1,l,mid);
    build(k<<1|1,mid+1,r);
    }


    void pushup(int k)
    {
    tree[k].num=max(tree[k<<1].num,tree[k<<1|1].num);
    }


    void pushdown(int k)
    {
    tree[k<<1].tag+=tree[k].tag;
    tree[k<<1|1].tag+=tree[k].tag;
    tree[k<<1].num+=tree[k].tag;
    tree[k<<1|1].num+=tree[k].tag;
    tree[k].tag=0;
    }


    void update(int k,int l,int r,int x)
    {
    if(tree[k].l==l && tree[k].r==r)
    {
    tree[k].num+=x;
    tree[k].tag+=x;
    return ;
    }
    if(tree[k].tag) pushdown(k);
    int mid=(tree[k].r+tree[k].l)>>1;
    if(r<=mid) update(k<<1,l,r,x);
    else if(l>=mid+1) update(k<<1|1,l,r,x);
    else
    update(k<<1,l,mid,x),update(k<<1|1,mid+1,r,x);
    pushup(k);
    }


    int query(int k,int l,int r)
    {
    if(tree[k].l==l&&tree[k].r==r)
    return tree[k].num;
    if(tree[k].tag) pushdown(k);
    int mid=(tree[k].l+tree[k].r)>>1;
    if(r<=mid) return query(k<<1,l,r);
    else if(l>=mid+1) return query(k<<1|1,l,r);
    else
    return max(query(k<<1,l,mid),query(k<<1|1,mid+1,r));
    }


    int main()
    {
    int t,x,y,len=0,flag[maxn],cas=1;
    scanf("%d",&t);
    while(t--)
    {
    len=0;
    memset(flag,0,sizeof(flag));
    scanf("%d%d",&k,&q);
    build(1,1,1000000);

    for(int i=1;i<=q;i++)
    {
    scanf("%d%d",&x,&y);
    y--;
    if(query(1,x,y)<k) 
    {
    flag[len++]=i;
    update(1,x,y,1);
    }      
    }
    printf("Case %d: ",cas++);
    for(int i=0;i<len;i++)
    printf("%d ",flag[i]);
    printf(" ");
    }

    return 0; 
    }


  • 相关阅读:
    angular 写 文字省略显示指令
    REACT 学习之一:普通表单过滤
    怎么能够做到实时的邮件监听-- 求指点
    C++实现Behavioral
    private virtual in c++
    接口污染
    C++ 虚函数&纯虚函数&抽象类&接口&虚基类(转)
    c++ override 关键字
    virtual function c++
    删完垃圾代码2
  • 原文地址:https://www.cnblogs.com/csushl/p/9386571.html
Copyright © 2020-2023  润新知