• poj 1611The Suspects


    The Suspects
    Time Limit: 1000MS   Memory Limit: 20000K
    Total Submissions: 29695   Accepted: 14456

    Description

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
    Once a member in a group is a suspect, all members in the group are suspects. 
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4
    1
    1
    这时AC代码
    #include<iostream>
    #define MAXN 40000
    using namespace std;
    int per[MAXN];
    int num[MAXN];
    int find(int x)
    {
        if(x!=per[x]){
            per[x]=find(per[x]);
        }
        return per[x];
    }
    void join(int x,int y)
    {
        int fx=find(x);
        int fy=find(y);
        if(fx==fy) return;
        if(num[fx]>=num[fy])
        {
            per[fy]=fx;
            num[fx]=num[fx]+num[fy];
        }else
        {
            per[fx]=fy;
            num[fy]=num[fy]+num[fx];
        }
        //cout<<num[per[0]]<<endl;
    }
    int main()
    {
        int n,m,t;
        while(cin>>n>>m)
        {
            if(n==0&&m==0) break;
            int a,b;
            for(int i=0;i<n;i++){
                per[i]=i;
                num[i]=1;
            }    
            while(m--)
            {
                cin>>t>>a;
                for(int i=1;i<t;i++)
                {
                    cin>>b;
                    join(a,b);
                }
            }
            cout<<num[per[0]]<<endl;
        }
        return 0;
    }
  • 相关阅读:
    MFC通过ODBC连接Mysql程序
    MFC下DLL编程(图解)
    INI文件的写入与读取
    如何在MFC中启动其它的(.exe)可执行文件
    [VC++]用CTime类得到当前日期、时间、星期,格式化(详细讲解)
    OutputDebugString输出调试信息到debugtrack
    MFC添加背景图片三种方法
    在MFC对话框中添加状态栏
    MFC 窗体背景图片设置
    MFC实现为窗体添加的背景图片
  • 原文地址:https://www.cnblogs.com/cniwoq/p/6770990.html
Copyright © 2020-2023  润新知