• poj-2996 Help Me with the Game


    Help Me with the Game
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 3210   Accepted: 2071

    Description

    Your task is to read a picture of a chessboard position and print it in the chess notation.

    Input

    The input consists of an ASCII-art picture of a chessboard with chess pieces on positions described by the input. The pieces of the white player are shown in upper-case letters, while the black player's pieces are lower-case letters. The letters are one of "K" (King), "Q" (Queen), "R" (Rook), "B" (Bishop), "N" (Knight), or "P" (Pawn). The chessboard outline is made of plus ("+"), minus ("-"), and pipe ("|") characters. The black fields are filled with colons (":"), white fields with dots (".").

    Output

    The output consists of two lines. The first line consists of the string "White: ", followed by the description of positions of the pieces of the white player. The second line consists of the string "Black: ", followed by the description of positions of the pieces of the black player. 

    The description of the position of the pieces is a comma-separated list of terms describing the pieces of the appropriate player. The description of a piece consists of a single upper-case letter that denotes the type of the piece (except for pawns, for that this identifier is omitted). This letter is immediatelly followed by the position of the piece in the standard chess notation -- a lower-case letter between "a" and "h" that determines the column ("a" is the leftmost column in the input) and a single digit between 1 and 8 that determines the row (8 is the first row in the input). 

    The pieces in the description must appear in the following order: King("K"), Queens ("Q"), Rooks ("R"), Bishops ("B"), Knights ("N"), and pawns. Note that the numbers of pieces may differ from the initial position because of capturing the pieces and the promotions of pawns. In case two pieces of the same type appear in the input, the piece with the smaller row number must be described before the other one if the pieces are white, and the one with the larger row number must be described first if the pieces are black. If two pieces of the same type appear in the same row, the one with the smaller column letter must appear first.

    Sample Input

    +---+---+---+---+---+---+---+---+
    |.r.|:::|.b.|:q:|.k.|:::|.n.|:r:|
    +---+---+---+---+---+---+---+---+
    |:p:|.p.|:p:|.p.|:p:|.p.|:::|.p.|
    +---+---+---+---+---+---+---+---+
    |...|:::|.n.|:::|...|:::|...|:p:|
    +---+---+---+---+---+---+---+---+
    |:::|...|:::|...|:::|...|:::|...|
    +---+---+---+---+---+---+---+---+
    |...|:::|...|:::|.P.|:::|...|:::|
    +---+---+---+---+---+---+---+---+
    |:P:|...|:::|...|:::|...|:::|...|
    +---+---+---+---+---+---+---+---+
    |.P.|:::|.P.|:P:|...|:P:|.P.|:P:|
    +---+---+---+---+---+---+---+---+
    |:R:|.N.|:B:|.Q.|:K:|.B.|:::|.R.|
    +---+---+---+---+---+---+---+---+
    

    Sample Output

    White: Ke1,Qd1,Ra1,Rh1,Bc1,Bf1,Nb1,a2,c2,d2,f2,g2,h2,a3,e4
    Black: Ke8,Qd8,Ra8,Rh8,Bc8,Ng8,Nc6,a7,b7,c7,d7,e7,f7,h7,h6

    Source

    /*题意:给出 棋盘 情况 输出 白棋 和 黑棋在 棋盘上的坐标
     
                白棋为大写字母 黑棋为小写字母
     
    棋盘 左下点为原点(1,a)
     
    输出 是 依照KQRBNP的顺序
     
    白棋 输出 行小的 行同样按列小的 先输出
     
    黑棋 行大的先输出 
    */
    #include<cstdio>
    #include<algorithm>
    #include<cstring>
    using namespace std;
    struct point
    {
        int x,y,p;
        char d;
    }w[65],f[65];
    
    bool cmp1(point a,point b) //黑
    {
        if(a.p!=b.p) return a.p<b.p;
        else if(a.x!=b.x) return a.x>b.x;
        else return a.y<b.y;
    }
    
    bool cmp2(point a,point b) //白
    {
        if(a.p!=b.p) return a.p<b.p;
        else if(a.x!=b.x) return a.x<b.x;
        else return a.y<b.y;
    }
    
    int solve(char c)
    {
        if(c=='K'||c=='k') return 1;
        else if(c=='Q'||c=='q') return 2;
        else if(c=='R'||c=='r') return 3;
        else if(c=='B'||c=='b') return 4;
        else if(c=='N'||c=='n') return 5;
        else return 6;
    }
    
    int main()
    {
        char s[105],a,b,c;
        int write=0,black=0;
        for(int i=8;i>=1;i--)
        {
            gets(s);
            for(int j=0;j<8;j++)
            {
                getchar();
                scanf("%c%c%c",&a,&b,&c);
                if(b=='.'||b==':') continue;
                if(b>='a'&&b<='z')  //黑
                {
                    w[write].x=i;
                    w[write].y=j;
                    w[write].d=b-32;
                    w[write++].p=solve(b);
                }
                else    //白
                {
                    f[black].x=i;
                    f[black].y=j;
                    f[black].d=b;
                    f[black++].p=solve(b);
                }
            }
            getchar();getchar();
        }
        sort(w,w+write,cmp1);
        sort(f,f+black,cmp2);
        gets(s);
        printf("White: ");
        for(int i=0;i<black;i++)
        {
            if(f[i].d!='P') printf("%c",f[i].d);
            printf("%c%d%c",f[i].y+'a',f[i].x,(i==black-1)?

    ' ':','); } printf("Black: "); for(int i=0;i<write;i++) { if(w[i].d!='P') printf("%c",w[i].d); printf("%c%d%c",w[i].y+'a',w[i].x,(i==write-1)?' ':','); } return 0; }


  • 相关阅读:
    java:IO流(处理流(缓冲流,转换流,数据流),对象的序列化,Properties)
    java:容器/集合(Map(HashMap,TreeMap)Collection和Collections,(Collection-value();)
    java:容器/集合Collection(List(ArrayList,LinkedList,Vector),Set(HashSet(LinkedHashSet),TreeSet))
    java:常用类(包装类,equals和==的比较,Date,java.lang.String中常用方法,枚举enum)
    java:LeakFilling(面向对象)
    java:异常机制(try,catch,finally,throw,throws,自定义异常)
    深入剖析Java中的装箱和拆箱
    Java 如何有效地避免OOM:善于利用软引用和弱引用
    浅谈Java中的hashcode方法
    浅析Java中的访问权限控制
  • 原文地址:https://www.cnblogs.com/clnchanpin/p/6991869.html
Copyright © 2020-2023  润新知