• hd acm1048


    Problem Description
    Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked.
    You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite:

    Cipher text
    A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

    Plain text
    V W X Y Z A B C D E F G H I J K L M N O P Q R S T U

    Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.
     
    Input
    Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase.

    A single data set has 3 components:

    Start line - A single line, "START"

    Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar

    End line - A single line, "END"

    Following the final data set will be a single line, "ENDOFINPUT".
     
    Output
    For each data set, there will be exactly one line of output. This is the original message by Caesar.
     
    Sample Input
    START
    NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX
    END
    START
    N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ
    END
    START
    IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ
    END
    ENDOFINPUT
     
    Sample Output
    IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES
    I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME
    DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE
     
    Sample Way
     

    #include <stdio.h>
    #include <stdlib.h>
    #include <ctype.h>
    #include <string.h>

    int main()
    {
      char cipher[3][200]; //用来存储每一个数据集
      int j,k;
      while(1)
      {
        for(j=0;j<3;j++)
        {
          gets(cipher[j]); //将每行的信息读入到数组中
          if(j==1)
          {
            k=0;
            while(cipher[1][k]!='') //破译密文
            {
            if(cipher[1][k]<'F'&&isupper(cipher[1][k]))
                 cipher[1][k]+=21;
            else if(isupper(cipher[1][k]))
               cipher[1][k]-=5;
            k++;
               }
          }
        }
      if(strcmp(cipher[0],"ENDOFINPUT")!=0) puts(cipher[1]); //输出结果
      if(strcmp(cipher[0],"ENDOFINPUT")==0) break; //输入结束的标志
      }
    return 0;
    }

  • 相关阅读:
    深入了解 Flink 网络栈(二):监控、指标和处理背压
    物联网安全技术提高区块链应用数据的可信度
    威胁快报|Bulehero挖矿蠕虫升级,PhpStudy后门漏洞加入武器库
    Ververica Platform-阿里巴巴全新Flink企业版揭秘
    重磅 | 阿里云与MongoDB达成战略合作,成为全球唯一提供最新版MongoDB的云厂商
    阿里巴巴叶军:政企数字化转型,现在是最重要的时机
    Canonical 开源 MicroK8 | 云原生生态周报 Vol. 25
    nyoj42——连通图加欧拉(连通图板子)dfs
    nyoj38——最小生成树
    nyoj20——有向无环图深搜模板
  • 原文地址:https://www.cnblogs.com/clljs/p/7423960.html
Copyright © 2020-2023  润新知