• Super Jumping! Jumping! Jumping!


    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 
    Your task is to output the maximum value according to the given chessmen list. 

    InputInput contains multiple test cases. Each test case is described in a line as follow: 
    N value_1 value_2 …value_N 
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 
    A test case starting with 0 terminates the input and this test case is not to be processed. 
    OutputFor each case, print the maximum according to rules, and one line one case. 
    Sample Input

    3 1 3 2
    4 1 2 3 4
    4 3 3 2 1
    0

    Sample Output

    4
    10
    3

    dp:

    #include<bits/stdc++.h>
    using namespace std;
    const int N = 1e5+10;
    typedef long long ll;
    ll a[N];
    ll dp[N];
    int main()
    {
        int n;
        while(cin>>n) {
            memset(dp,0,sizeof(dp));
            if( !n ) {
                break;
            }
            for(int i = 0; i < n; i++) {
                cin>>a[i];
            }
            ll maxn = -N;
            for(int i = 0; i < n; i++) {
                dp[i] = a[i];
                for(int j = 0; j < i; j++) {
                    if(a[i] > a[j]) {
                        dp[i] = max(dp[i],dp[j]+a[i]);
                    }
                }
                if(dp[i] > maxn) {
                   maxn = dp[i];
                }
            }
            cout<<maxn<<endl;
        }
    }
    

      

  • 相关阅读:
    java8新特性之Lambda表达式入门
    小结
    Kafka入门
    关于java多线程初试
    关于Netty入门
    IOS UITableView代码添加数据源和指定委托
    C#读书笔记1
    vs2008 C# Windows Mobile 智能设备开发 初步1
    Microsoft ActiveSync简介(来自网络)
    winForm单击用户区可移动窗体,代码控制窗体最大适中
  • 原文地址:https://www.cnblogs.com/clb123/p/11930186.html
Copyright © 2020-2023  润新知