• POJ 3280 Cheapest Palindrome


    Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

    Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

    FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

    Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

    Input

    Line 1: Two space-separated integers: N and M 
    Line 2: This line contains exactly M characters which constitute the initial ID string 
    Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

    Output

    Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

    Sample Input

    3 4
    abcb
    a 1000 1100
    b 350 700
    c 200 800

    Sample Output

    900

    Hint

    If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.
     

    区间动态规划

    我们可以设dp[i][j]代表将IJ这一段变为回文的最小代价,然后便可以发现它可以由以下三种情况转移来得到:

    1.a[l]==a[r]   可以直接由dp[l+1][r-1]转移而来(因为dp[l+1][r-1]已经在前面更新过,已经是回文的了).

    2.a[l+1]==a[r] 那么我们可以通过删除a[l]或者通过添加一个与a[i]相同的字符来完成对dp[l][r]的修改,使其成为回文串,即dp[l][r]=min(dp[l][r],dp[l+1][r]+str[a[l]]).

    3. a[l]==a[r-1]  2同理,稍稍做些修改即可.

       转移时注意要由先枚举长度,由小区间取更新大区间来得到大区间的最优值。最后的答案就是dp[0][m-1].

    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<iostream>
    #include<cmath>
    #include<algorithm>
    #include<vector>
    #include<stack>
    #include<queue>
    #include<map>
    #define RG register
    #define IL inline
    #define pi acos(-1.0)
    #define ll long long 
    using namespace std;
    int n,m;
    char a[2500];
    map <char,int> s;
    int dp[2500][2500];//代表将I到J这一段变为回文的最小代价
    int main() {
      scanf("%d%d",&n,&m);
      scanf("%s",a);
      for(int i=1;i<=n;i++){
         char str;
         int del,add;
         cin>>str;
         scanf("%d%d",&add,&del);
         s[str]=min(add,del);
      }
      memset(dp,50,sizeof(dp));
      for(int i=0;i<m;i++)  dp[i][i]=0;
      for(int i=2;i<=m;i++)//拿已经是回文的小区间取更新大的区间
        for(int l=0,r=0+i-1;r<m;++l,++r){
          if(a[l]==a[r]){
        if((l+1)>(r-1)) dp[l][r]=0;
        else dp[l][r]=dp[l+1][r-1];
        //已经是回文了,直接赋值即可
          } else{
        dp[l][r]=min(dp[l][r],dp[l+1][r]+s[a[l]]);
        dp[l][r]=min(dp[l][r],dp[l][r-1]+s[a[r]]);
            //把原来不是回文的变成回文的
          }
        }
      printf("%d",dp[0][m-1]);
      return 0;
    }
  • 相关阅读:
    【转】如何保护自己的QQ号
    13. 查看数据库对象间的依赖关系
    12. 查询数据库账号的所有权限
    11. 查询数据库各种历史记录
    如何找回SQL Server实例安装时的序列号
    SQL Server Mobile/Compact Edition 简单介绍
    6. SQL Server数据库监控
    5. SQL Server数据库性能监控
    4. SQL Server数据库状态监控
    3. SQL Server数据库状态监控
  • 原文地址:https://www.cnblogs.com/cjoier-nfy/p/7436699.html
Copyright © 2020-2023  润新知