• 2015 HUAS Summer Training#2~E


    Description

    Download as PDF
     

    A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

    Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

    Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

    Input Specification

    The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

    Output Specification

    For each test case, print one line saying "To get from xx to yy takes n knight moves.".

    Sample Input

    e2 e4
    a1 b2
    b2 c3
    a1 h8
    a1 h7
    h8 a1
    b1 c3
    f6 f6

    Sample Output

    To get from e2 to e4 takes 2 knight moves.
    To get from a1 to b2 takes 4 knight moves.
    To get from b2 to c3 takes 2 knight moves.
    To get from a1 to h8 takes 6 knight moves.
    To get from a1 to h7 takes 5 knight moves.
    To get from h8 to a1 takes 6 knight moves.
    To get from b1 to c3 takes 1 knight moves.
    To get from f6 to f6 takes 0 knight moves.

     解题思路:该问题不需要求出该两点间的路径上的点,也不需要求出拥有该最短步数的路径个数,只需将其间的最短步数求出即可;该问题不仅需要求出两点间的最短路径,且要求出这样的最短路径有多少条和每一条路径上的每一点;找出从S出发到达D的所有路径长度小于6的路径,然后再从这些路径中寻找最短路径

    程序代码:

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <queue>
    using namespace std;
    int c[9][9];
    int dir[8][2] = {{-2,-1},{-2,1},{-1,2},{1,2},{2,1},{2,-1},{1,-2},{-1,-2}};
    typedef struct
    {
        int x,y,count;
    }node;
    node start,finish;
    int bfs()
    {
        memset(c,0,sizeof(c));
        node pre,cur;
        start.count = 0;
        queue<node> q;
        q.push(start);
        c[start.x][start.y] = 1;
        while(!q.empty())
        {
            pre = q.front();
            q.pop();
            if(pre.x == finish.x&&pre.y == finish.y)
            return pre.count;
            for(int i = 0; i < 8; i++)
            {
                cur.x = pre.x + dir[i][0];
                cur.y = pre.y + dir[i][1];
                if(cur.x<1||cur.x>8||cur.y<1||cur.y>8)continue;
                if(c[cur.x][cur.y]==1)continue;
                c[cur.x][cur.y] = 1;
                cur.count = pre.count + 1;
                q.push(cur);
            }
        }
        return -1;
    }
    int main()
    {
        char row,end;
        int col,ed;
        int min;
        while(scanf("%c",&row)!=EOF)
        {
            scanf("%d",&col);
            getchar();
            scanf("%c%d",&end,&ed);
            getchar();
            start.x = row-'a'+1;
            start.y = col;
            finish.x = end-'a'+1;
            finish.y = ed;
            if(start.x==finish.x&&start.y==finish.y)
            min = 0;
            else  min = bfs();
            printf("To get from %c%d to %c%d takes %d knight moves. ",row,col,end,ed,min);
        }
        return 0;
    }

  • 相关阅读:
    悼念512汶川大地震遇难同胞——珍惜现在,感恩生活--hdu2191(多重背包模板)
    Gunner II--hdu5233(map&vector/二分)
    Geometric Progression---cf 567C(求组合方式,map离散)
    Guess Your Way Out! II---cf 558D (区间覆盖,c++STL map 的使用)
    Amr and Chemistry---cf558C(暴力,加技巧)
    汉诺塔IV---hdu2077
    Safe Or Unsafe--hdu2527(哈夫曼树求WPL)
    Divisibility by Eight---cf550C(被8整除 暴力)
    Charles使用技巧
    RabbitMQ-高级特性(六)
  • 原文地址:https://www.cnblogs.com/chenchunhui/p/4671761.html
Copyright © 2020-2023  润新知