• 1005. Spell It Right


    1005. Spell It Right (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

    Input Specification:

    Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

    Output Specification:

    For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

    Sample Input:
    12345
    
    Sample Output:
    one five
    import java.util.Scanner;
    
    public class Main {
    
        public static void main(String[] args) {
            Scanner in=new Scanner(System.in);
            String n,str[]=new String [101];
            Integer sum=0;
            n=in.next();
            String s[]={"zero","one","two","three","four","five","six","seven"
                    ,"eight","nine"};
            for(int i=0;i<n.length();i++){
                sum=sum+n.charAt(i)-'0';
            }
            
            int len=sum.toString().length();
            while(len!=0){
                if(len!=1){
                    System.out.print(s[(int) (sum/Math.pow(10,len-1))]+" ");
                }
                else{
                    System.out.print(s[(int) (sum/Math.pow(10,len-1))]);
                }
                sum=(int) (sum%(Math.pow(10,len-1)));
                len--;
            }
    
        }
    
    }

    注意点:10^100int和double都不够,所以当做字符串读进来在进行计算

    错误代码:

    import java.util.Scanner;
    
    public class Main {
    
      public static void main(String[] args) {
        Scanner in=new Scanner(System.in);
        double n;
        Integer sum=0;
        n=in.nextDouble();
        String s[]={"zero","one","two","three","four","five","six","seven"
            ,"eight","nine"};
        while(n!=0){
          sum=(int) (sum+n%10);
          n=n/10;
        }
        int len=sum.toString().length();
        while(len!=0){
          if(len!=1){
            System.out.print(s[(int) (sum/Math.pow(10,len-1))]+" ");
          }
          else{
            System.out.print(s[(int) (sum/Math.pow(10,len-1))]);
          }
          sum=(int) (sum%(Math.pow(10,len-1)));
          len--;
        }
    
      }
    
    }
    
    

      结果

    参考

    http://blog.csdn.net/zhangveni/article/details/50878369

  • 相关阅读:
    cocos2d 多点触摸
    mac 下安装node.js
    黑鹰破解笔记(2)
    OD使用心得笔记二
    淘宝店开始进行审核
    黑鹰破解笔记(1)
    Lisp笔记1
    OD使用心得笔记一
    怒马
    近段时间的web开发
  • 原文地址:https://www.cnblogs.com/chen20135517/p/7689203.html
Copyright © 2020-2023  润新知