• CF49A Sleuth


    题目描述

    Vasya plays the sleuth with his friends. The rules of the game are as follows: those who play for the first time, that is Vasya is the sleuth, he should investigate a "crime" and find out what is happening. He can ask any questions whatsoever that can be answered with "Yes" or "No". All the rest agree beforehand to answer the questions like that: if the question’s last letter is a vowel, they answer "Yes" and if the last letter is a consonant, they answer "No". Of course, the sleuth knows nothing about it and his task is to understand that.

    Unfortunately, Vasya is not very smart. After 5 hours of endless stupid questions everybody except Vasya got bored. That’s why Vasya’s friends ask you to write a program that would give answers instead of them.

    The English alphabet vowels are: A, E, I, O, U, Y

    The English alphabet consonants are: B, C, D, F, G, H, J, K, L, M, N, P, Q, R, S, T, V, W, X, Z

    输入输出格式

    输入格式:

     

    The single line contains a question represented by a non-empty line consisting of large and small Latin letters, spaces and a question mark. The line length does not exceed 100. It is guaranteed that the question mark occurs exactly once in the line — as the last symbol and that the line contains at least one letter.

     

    输出格式:

     

    Print answer for the question in a single line: YES if the answer is "Yes", NO if the answer is "No".

    Remember that in the reply to the question the last letter, not the last character counts. I. e. the spaces and the question mark do not count as letters.

     

    输入输出样例

    输入样例#1: 复制
    Is it a melon?
    
    输出样例#1: 复制
    NO
    
    输入样例#2: 复制
    Is it an apple?
    
    输出样例#2: 复制
    YES
    
    输入样例#3: 复制
      Is     it a banana ?
    
    输出样例#3: 复制
    YES
    
    输入样例#4: 复制
    Is   it an apple  and a  banana   simultaneouSLY?
    
    输出样例#4: 复制
    YES

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    char s[1000];
    int main(){
        scanf("%[^
    ]",s);
        int len=strlen(s)-1;
        for(int i=len;i>=0;i--)
            if(s[i]>='a'&&s[i]<='z'||s[i]>='A'&&s[i]<='Z'){
                if(s[i]=='A'||s[i]=='a'||s[i]=='E'||s[i]=='e'||s[i]=='I'||s[i]=='i'||s[i]=='O'||s[i]=='o'||s[i]=='U'||s[i]=='u'||s[i]=='Y'||s[i]=='y')    cout<<"YES";
                else cout<<"NO";
                return 0;
            }
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    Bitcoin core核心客户端在CentOS7上的安装和配置
    Struts的标签及JSTL和EL表达式的使用总结
    Java反编译
    Tomcat 各版本 配置SSI服务实现html模块化实现#include virtual="static/_header.html"
    33
    SQL Server Management Studio无法记住密码
    SQL Server 创建角色和账号
    JS 取出DataGrid 列
    关于HTTP协议的小实验
    DNS服务操作小实验
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/8440884.html
Copyright © 2020-2023  润新知