• proj1017


    Packets
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 40681   Accepted: 13645

    Description

    A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

    Input

    The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

    Output

    The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

    Sample Input

    0 0 4 0 0 1 
    7 5 1 0 0 0 
    0 0 0 0 0 0 

    Sample Output

    2 
    1 

    Source

     
     
    #include<iostream>
    
    using namespace std;
    
    void print(int *a){
    	for(int i = 0; i < 6; ++i){
    		cout<<a[i]<<" ";
    	}
    	cout<<endl;
    }
    
    int parcels(int *a){
    	int count = 0;
    	count += a[5] + a[4];
    	if(a[0] <= a[4]*11){
    		a[0] = 0;
    	}else{
    		a[0] -= a[4]*11;
    	}
    	a[5] = 0;
    	a[4] = 0;
    	count += a[3];
    	if(a[1] <= a[3]*5){
    		if(a[0] <= (a[3]*5 - a[1])*4){
    			a[0] = 0;
    		}else{
    			a[0] -= (a[3]*5 - a[1])*4;
    		}
    		a[1] = 0;
    	}else{
    		a[1] -= a[3]*5;
    	}
    	a[3] = 0;
    	if(a[2]%4 == 0){
    		count += a[2]/4;
    	}else{
    		count += a[2]/4 + 1;
    
    		if(a[1] <= (7 - (a[2]%4)*2)){
    			if(a[0] <= 8 - (a[2]%4) + (7 - (a[2]%4)*2 - a[1])*4){
    				a[0] = 0;
    			}else{
    				a[0] -= 8 - (a[2]%4) + (7 - (a[2]%4)*2 - a[1])*4;
    			}
    			a[1] = 0;
    		}else{
    			a[1] -= (7 - (a[2]%4)*2);
    			if(a[0] <= 8 - (a[2]%4)){
    				a[0] = 0;
    			}else{
    				a[0] -= 8 - (a[2]%4);
    			}
    		}
    	}
    	a[2] = 0;
    	if(a[1] != 0){
    		if(a[1]%9 == 0){
    			count += a[1]/9;
    		}else{
    			count += a[1]/9 + 1;
    			if(a[0] <= (9 - (a[1]%9))*4){
    				a[0] = 0;
    			}else{
    				a[0] -= (9 - (a[1]%9))*4;
    			}
    		}
    	}
    	a[1] = 0;
    	count += (35 + a[0])/36;
    	a[0] = 0;
    	return count;
    }
    
    int main()
    {
    
    
    	int a[6];
    	for(int i = 0; i < 6; ++i){
    		cin>>a[i];
    	}
    	while(!(a[0] == 0&&a[1] == 0&&a[2] == 0&&a[3] == 0&&a[4] == 0&&a[5] == 0)){
    		cout<<parcels(a)<<endl;
    		for(int i = 0; i < 6; ++i){
    			cin>>a[i];
    		}
    	}
    
    	return 0;
    }
     
  • 相关阅读:
    sqlserver 测试sql语句执行时间
    最大子数组问题(求连续子数组的最大和)
    字符、字节和编码
    Android 的数据存储——SharePreferences
    TCP、UDP原理及比较
    计算机常识——软件系统体系结构
    三个线程循环打印ABC10次的几种解决方法
    Analysis of Algorithms--preface
    Java native方法、JNI实例及常见错误分析
    随笔-2014-9-30
  • 原文地址:https://www.cnblogs.com/candycloud/p/3404735.html
Copyright © 2020-2023  润新知