• poj-3181 Dollar Dayz


    完全背包。+实现俩个大数相加。
    Dollar Dayz
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 3431   Accepted: 1356

    Description

    Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 
            1 @ US$3 + 1 @ US$2
             1 @ US$3 + 2 @ US$1
             1 @ US$2 + 3 @ US$1
             2 @ US$2 + 1 @ US$1
             5 @ US$1
    Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

    Input

    A single line with two space-separated integers: N and K.

    Output

    A single line with a single integer that is the number of unique ways FJ can spend his money.

    Sample Input

    5 3

    Sample Output

    5
    #include<iostream>
    #include<cstring>
    using namespace std;
    __int64 temp,a[1010],b[1010];
    int main()
    {
        int i,j,n,k;
         cin>>n>>k;
          temp=1;
          memset(a,0,sizeof(a));
          memset(b,0,sizeof(b));
         for(i=0;i<18;i++)
           temp*=10;//__int64存放18位。
         a[0]=1;
         for(i=1;i<=k;i++)//i是金币
          for(j=1;j<=n;j++)//j是总额。
             {
                 if(i>j)
                   continue; 
                   b[j]=b[j]+b[j-i]+(a[j]+a[j-i])/temp;//加上进位,以18位为一个进位。
                a[j]=(a[j]+a[j-i])%temp;//不能调换
               
                 
             }
             if(b[n])
              cout<<b[n];
              cout<<a[n]<<endl;
       return 0;
    }
    
  • 相关阅读:
    css常见布局问题
    jsonp原理及同源策略
    执行webpack-dev-server时,提示端口被占用。
    PHP中的<<<运算符
    PHP中的字符串类型
    数据库系统的结构
    HDU 2516 取石子游戏
    常用MySql命令列选
    mysql简单语句
    微信小程序-循环
  • 原文地址:https://www.cnblogs.com/cancangood/p/3581216.html
Copyright © 2020-2023  润新知