• HDU-2955 Robberies


               01背包的概率问题

            http://acm.hdu.edu.cn/showproblem.php?pid=2955    

      状态方程 :dp[j]=max(dp[j],dp[j-m[i]]*1-pi[i]);

      思路是:  

    当前的概率基于前一种状态的概率,即偷n家银行而不被抓的概率等于偷n-1家银行不被转的概率乘以偷第n家银行不被抓的概率。

    dp[i]表示偷价值为 i 时不被抓的概率,则状态转移方程为:

              dp[j] = max(dp[j] , dp[j-m[i]] * (1-p[i]));

                                  Robberies

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 9334    Accepted Submission(s): 3489

    Problem Description
    The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.
    For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.
    His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
     
    Input
    The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
     
    Output
    For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.
    Notes and Constraints 0 < T <= 100 0.0 <= P <= 1.0 0 < N <= 100 0 < Mj <= 100 0.0 <= Pj <= 1.0 A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
     
    Sample Input
    3
    0.04 3
    1 0.02
    2 0.03
    3 0.05
    0.06 3
    2 0.03
    2 0.03
    3 0.05
    0.10 3
    1 0.03
    2 0.02
    3 0.05
     
    Sample Output
    2
    4
    6
    #include <iostream> 
    #include <algorithm>
    using namespace std;
    int main()
    {
    	int i,t,n,sum,j;
    	double p;
    	int  m[200];
       double pi[200],dp[10001];
         cin>>t;
    	 while(t--)
    	 {
    		  sum=0;
    		 cin>>p>>n;
    		 p=1-p;
             for(i=0;i<n;i++)
    		 { 
    		    cin>>m[i]>>pi[i];
                 sum+=m[i];
    			 pi[i]=1-pi[i];
    		 }
    		 memset(dp,0,sizeof(dp));
    		 dp[0]=1;
    		 for(i = 0;i < n;i++) 
                for(j = sum;j >= m[i];j--)
                    if(dp[j]<dp[j-m[i]]*pi[i])
    				  dp[j] = dp[j-m[i]]*pi[i];
    		    for(i = sum;i >= 0;i--)
    		      if(dp[i]>p)
    			  {
    				  cout << i << endl;
    			      break;
    			  }
    			  
         }
    	 return 0;
    }
    
  • 相关阅读:
    HTML5就是现在:深入了解Polyfills
    dot.js-js模板引擎使用,教程,入门
    js操作dom对象
    JavaScript中this详解
    浅谈JavaScript中的string拥有方法的原因
    函数定义方式
    Jquery的跨域调用
    数据结构与算法之美-排序(下)
    CLR via C#学习笔记-第十三章-定义接口、继承接口
    CLR via C#学习笔记-第十二章-可验证性和约束
  • 原文地址:https://www.cnblogs.com/cancangood/p/3554549.html
Copyright © 2020-2023  润新知